Welcome App problem

I have just installed EOS via online installer to a friend’s laptop, with Plasma as the only DE. However the Welcome app is misbehaving.

If I click the close at top right, nothing happens. Same with Don’t show me anymore. Eventually KDE figures out Yad is not responding, so I can kill it.
Nothing is put to CLI in the way of debug messages either.

System:    Kernel: 5.12.9-arch1-1 x86_64 bits: 64 compiler: gcc v: 11.1.0 Desktop: KDE Plasma 5.21.5 tk: Qt 5.15.2 
           wm: kwin_wayland dm: SDDM Distro: EndeavourOS base: Arch Linux 
Machine:   Type: Laptop System: TOSHIBA product: Satellite P75-A v: PSPLNU-00H004B serial: <filter> 
           Mobo: Type2 - Board Vendor Name1 model: Type2 - Board Product Name1 v: Type2 - Board Version serial: <filter> 
           UEFI-[Legacy]: Insyde v: 1.00 date: 05/02/2013 
Battery:   ID-1: BAT1 charge: 42.7 Wh (100.0%) condition: 42.7/48.6 Wh (87.8%) volts: 12.4 min: 10.8 
           model: Panasonic PA5121U-1BRS serial: N/A status: Full 
           Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M325 serial: <filter> charge: 100% (should be ignored) 
           status: Discharging 
CPU:       Info: Quad Core model: Intel Core i7-4700MQ bits: 64 type: MT MCP arch: Haswell rev: 3 cache: L2: 6 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 38324 
           Speed: 2392 MHz min/max: 800/3400 MHz Core speeds (MHz): 1: 2392 2: 1424 3: 1312 4: 2395 5: 2395 6: 2339 7: 2395 
           8: 2395 
Graphics:  Device-1: Intel 4th Gen Core Processor Integrated Graphics vendor: Toshiba driver: i915 v: kernel bus-ID: 00:02.0 
           chip-ID: 8086:0416 
           Device-2: IMC Networks TOSHIBA Web Camera - HD type: USB driver: uvcvideo bus-ID: 1-1.4:4 chip-ID: 13d3:5606 
           Display: wayland server: X.org 1.20.11 compositor: kwin_wayland driver: loaded: intel 
           unloaded: fbdev,modesetting,vesa resolution: <missing: xdpyinfo> 
           Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:     Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio vendor: Toshiba driver: snd_hda_intel v: kernel 
           bus-ID: 00:03.0 chip-ID: 8086:0c0c 
           Device-2: Intel 8 Series/C220 Series High Definition Audio vendor: Toshiba driver: snd_hda_intel v: kernel 
           bus-ID: 00:1b.0 chip-ID: 8086:8c20 
           Sound Server-1: ALSA v: k5.12.9-arch1-1 running: yes 
           Sound Server-2: JACK v: 0.125.0 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: yes 
           Sound Server-4: PipeWire v: 0.3.29 running: yes 
Network:   Device-1: Intel Centrino Wireless-N 2230 driver: iwlwifi v: kernel port: 5040 bus-ID: 01:00.0 chip-ID: 8086:0887 
           IF: wlan0 state: up mac: <filter> 
           Device-2: Qualcomm Atheros AR8161 Gigabit Ethernet vendor: Toshiba driver: alx v: kernel port: 3000 bus-ID: 07:00.0 
           chip-ID: 1969:1091 
           IF: enp7s0 state: down mac: <filter> 
Bluetooth: Device-1: Intel Centrino Bluetooth Wireless Transceiver type: USB driver: btusb v: 0.8 bus-ID: 1-1.3:3 
           chip-ID: 8087:07da 
           Report: This feature requires one of these tools: hciconfig/bt-adapter 
Drives:    Local Storage: total: 817.88 GiB used: 76.65 GiB (9.4%) 
           ID-1: /dev/sda vendor: SanDisk model: SDSSDHP128G size: 119.24 GiB speed: 3.0 Gb/s serial: <filter> 
           ID-2: /dev/sdb vendor: HGST (Hitachi) model: HTS541075A9E680 size: 698.64 GiB speed: 3.0 Gb/s serial: <filter> 
Partition: ID-1: / size: 100.14 GiB used: 11.98 GiB (12.0%) fs: ext4 dev: /dev/sda1 
Swap:      ID-1: swap-1 type: partition size: 16.94 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 46.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 264 Uptime: 3h 07m Memory: 15.4 GiB used: 2.32 GiB (15.1%) Init: systemd v: 248 Compilers: gcc: 11.1.0 
           Packages: pacman: 1141 Shell: Bash v: 5.1.8 running-in: konsole inxi: 3.3.03 

it happens sometimes that the welcome app is not responding on plasma but should not happen every time.

It is a yad problem, and as Joe said, it occurs occasionally.
Hopefully yad devs will fix it.

1 Like

Ok, so it is a problem at every boot with this machine. I tried setting it to disable in the EOS-greeting.conf, but that didn’t stop it appearing. How can I turn it off? Removing it is an issue due to the cascade of dependencies.

pactree -r welcome doesn’t show other packages being dependent on welcome so it should be safe to run sudo pacman -R welcome I guess .

Otherwise you could try disabling it:
eos-welcome --disable


Thanks @peback. Removing it resulted in a Yad window popping up at next reboot. Disabling it via the method you suggested works. :beers:

1 Like

Or just tell it you don’t want to see it anymore. It will go away with a sad face and not start anymore but can be launched should the need arise.

That was part of the issue…those buttons don’t work. Click, goes grey, yad stops responding.

The is a reason for that but a solved thread is solved :+1:


Strange. Maybe a plasma vs. yad problem.
I’ll look into it as soon as possible.

In my VM with Plasma Welcome buttons do work as expected.
Is it possible that your system is not properly updated?

sudo pacman -Syyuu

might help.

Yes, it was completely up to date when first noticed, then an EOS Welcome came down the line, but didn’t change anything.
Doesn’t matter now, as it’s disabled, but this will surely affect someone else, as there is nothing special about this Toshiba Satellite.
Cheers, mate!

By the way, this yad window doesn’t disappear on my VM either. The updates are all fully installed. The window appears every time the system is started. Yes, KDE.

1 Like

I was thinking also those .pacnew files, have you handled them too (e.g. with

It looks like quite many people do not handle .pacnew (and related) files properly, and eventually it may cause problems.

Nope, hadn’t touched them. This was a brand new online install, straight from the 170421 verion on USB.

Yad has some problems with Welcome, for example clicking the See you later button a bit “carelessly” (move the mouse while clicking) doesn’t close the window, and then only clicking the (X) kills it.

So far I haven’t found a reason nor a good workaround for it.

It’s all very strange. Previously, the YAD window appeared regularly…
Now I have made 4 cold starts in the virtual machine - no windows except Welcome! it no longer appeared on the screen :face_with_raised_eyebrow:

That sounds like the “Don’t Show Me Anymore” button worked for you, so it’s not showing up now.

I didn’t press any buttons :slight_smile: But Welcome! now it starts at system startup without additional windows :slight_smile:

I returned the old yad workaround to Welcome. The workaround kills those “zombie” yad windows. There is also another workaround in Welcome for the same problem, but it doesn’t seem to catch all cases.

It is related to the “save desktop” feature (in Xfce it is called Automatically save session on logout). For some reason yad does not kill all processes at exit, so a workaround was created in Welcome. This is an old issue, and for a moment I thought that yad devs had already solved it, but apparently not.