Weird dual boot issue

Yesterday I noticed that cumulative Windows updates are failing at the last step. Even Arch wiki has an article about this to “make the Windows partition active” for the duration of running updates, however I have a slight problem, all of my disks are confirmed & double-confirmed to be GPT disks and I have failed to find wisdom on the internet what to do in that case.

Also on the Windows side all folders on NTFS partitions show up as ‘ready-only’, but they are clearly not read-only. The joys of having to use Windows once or twice a week…

When installing Endeavor I was possessed by a virgin ghost as a result I installed grub on my Windows drive’s old EFI folder. I see clearly now why that was a horrible idea, since it would be so easy to just reinstall Windows now, except it’s not…
Can I just follow these steps to move my EFI? (I have enough backup latitude to just yolo it, but it would take a lot of time for a failure) I faintly recall something about E-os having a slightly different /boot schema…

Do you get any error message indicating what might be wrong?

Sharing the same ESP between Linux and Windows shouldn’t, in principle, cause any update failure on Windows side so perhaps something else is going on.

If by this you mean you want to create a separate ESP for your EnOS system then those instructions from the link you have posted are not relevant in your case.

Please post the output of the following commands for forum members to have some idea about your disk layout:

sudo parted -l

Do you perform a proper shutdown of Windows (no Fast Startup, no hibernation) before booting into EnOS?

Model: ATA WDC WDS480G2G0A- (scsi)
Disk /dev/sda: 480GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system     Name    Flags
 1      1049kB  155GB  155GB   btrfs           ark1
 2      155GB   166GB  10,9GB  linux-swap(v1)  swap    swap
 3      167GB   480GB  313GB   ext4            Speedy

Model: ATA TOSHIBA HDWD130 (scsi)
Disk /dev/sdb: 3001GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                  Flags
 1      16,8MB  3001GB  3001GB  ntfs         Basic data partition  msftdata

Model: ATA WDC WD20EARS-00M (scsi)
Disk /dev/sdc: 2000GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start  End     Size    File system  Name                  Flags
 1      135MB  2000GB  2000GB  ntfs         Basic data partition  msftdata

Model: PM951 NVMe SAMSUNG 256GB (nvme)
Disk /dev/nvme0n1: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system  Name                          Flags
 1      1049kB  106MB  105MB   fat32        EFI system partition          bios_grub, no_automount
 2      106MB   123MB  16,8MB               Microsoft reserved partition  msftres, no_automount
 3      123MB   127GB  127GB   ntfs         Basic data partition          msftdata
 4      127GB   128GB  644MB   ntfs                                       hidden, diag, no_automount
 5      128GB   256GB  128GB   ntfs         gW                            msftdata

Also fast startup is disabled. I thought hibernation was also disabled, but apparently It got re-enabled over the past 2 years of random updates.

BootCurrent: 0000
Timeout: 2 seconds
BootOrder: 0000,0002,0001,0003
Boot0000* endeavouros   HD(1,GPT,0c6ef9a6-2f81-4757-bc4a-b906d4c8f4a5,0x800,0x32000)/File(\EFI\ENDEAVOUROS\GRUBX64.EFI)
Boot0001* Windows Boot Manager  HD(1,GPT,0c6ef9a6-2f81-4757-bc4a-b906d4c8f4a5,0x800,0x32000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)57494e444f5753000100000088000000780000004200430044004f0042004a004500430054003d007b00390064006500610038003600320063002d0035006300640064002d0034006500370030002d0061006300630031002d006600330032006200330034003400640034003700390035007d00000000000100000010000000040000007fff0400
Boot0002* neon  HD(1,GPT,0c6ef9a6-2f81-4757-bc4a-b906d4c8f4a5,0x800,0x32000)/File(\EFI\NEON\SHIMX64.EFI)
Boot0003  ubuntu        VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)

There are some leftovers, probably I should clean that I up, if I ever sort out my current problem.

I suppose this is the ESP shared between Windows and EnOS.

If so, use a partition manager (like Gparted) and change the flags to boot,esp.

Reboot into your Windows and try to update again.

1 Like

Thank you for the valuable input, I must admit I’m a bit shocked the boot flag is not set. :slight_smile:
I’ll check this after my gaming session. (have to restore the whole Windows partition from backup first as well, because I completely destroyed Windows Update during some Windows related troubleshooting steps)

If just Capture One worked on Linux I could just completely move on from Windows… le sigh

Thank you so much, this worked in fixing the Windows update problem, which is basically problem solved medium term!

Eventually I’ll have to reinstall Windows though (it’s an old install with some significant Windows rot piled up) and before I do that I really want to move the ESP to my current main drive. While it was stupid of me to install grub on Windows’s old EFI partition, I have predicted that someday I might have to do this, so I do have some (1gb or so) unclaimed storage prepared for this on my Linux ssd. What would be the recommended procedure to do this? (the end goal is the make E bootable with just its own ssd connected to the computer, that while using Grub 2)

Follow the steps here below:

  1. create a new partition on that space and format it as FAT32
  2. edit /etc/fstab and change the UUID for ESP with the one from the new ESP (mounted at /boot/efi)
  3. sudo systemctl daemon-reload && sudo mount -a
  4. sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=EnOS
  5. sudo grub-mkconfig -o /boot/grub/grub.cfg

To avoid Windows’ installer to use any already existent ESP on any other disks, make sure that you disable boo,esp flags on them. Doing so will result in the creation of a new ESP for Windows.

Later you could boot back into your EnOS and regenerate your grub.cfg to get a boot entry for Windows on the Grub boot menu.

I have developed the brutish practice to unplug drives the Windows installer has no business touching ^

Anyway, you are the best, thank you for the amazing help!

1 Like

That’s good! You don’t have to be worried then for any interference from the Windows’ installer.

In case you will have any issues or errors with the procedure posted above, please post here on the forum.

Good luck!


1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.