Weird bug with endeavourOS. Display refresh three times, logging OUT

I am newbie on this OS, I could installed it, and EndeavourOS works, but I have this annoying bug.

When I click some buttons like taskbar or welcome app the display goes off and gets on again, if you don’t save monitor config, you will get a default monitor config warning. this bug happens with any desktop or window option.

That is not the bug, the real bug is, if the display goes off and gets on again three times, it begins the logging out process, all apps are closed, nothing is saved and I have to log in again.

The chance of happening that is bigger if you left idle the PC some time.

my system info:

[clyde@clyde-hpcompaqdc7700smallformfactor ~]$ inxi -Fxxxaz
  Kernel: 6.1.12-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-linux-zen
    root=UUID=18070e78-55ad-4dc0-ac89-482a7d45a9b3 rw nowatchdog
    nvme_load=YES resume=UUID=7bbc7fcf-44a3-4142-9a4c-0c7f0fbf0f5c loglevel=3
    i915.enable_psr=0 i915.enable_fbc=0
  Desktop: LXQt v: 1.2.1 tk: Qt v: 5.15.8 info: lxqt-panel wm: Openbox
    v: 3.6.1 vt: 7 dm: LightDM v: 1.32.0 Distro: EndeavourOS base: Arch Linux
  Type: Desktop System: Hewlett-Packard product: HP Compaq dc7700 Small Form
    Factor v: N/A serial: <superuser required> Chassis: type: 4
    serial: <superuser required>
  Mobo: Hewlett-Packard model: 0A54h serial: <superuser required>
    BIOS: Hewlett-Packard v: 786E1 v01.09 date: 01/05/2007
  Info: model: Intel Pentium D bits: 64 type: MCP arch: Netburst Presler
    level: v1 built: 2006 process: Intel 65nm family: 0xF (15) model-id: 6
    stepping: 5 microcode: 0x7
  Topology: cpus: 1x cores: 2 smt: <unsupported> cache: L1: 32 KiB
    desc: d-2x16 KiB L2: 4 MiB desc: 2x2 MiB
  Speed (MHz): avg: 3192 min/max: N/A cores: 1: 3192 2: 3192 bogomips: 12767
  Flags: ht lm nx pae sse sse2 sse3
  Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf mitigation: PTE Inversion
  Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode;
    SMT disabled
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass status: Vulnerable
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, STIBP: disabled, RSB filling,
    PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel 82Q963/Q965 Integrated Graphics vendor: Hewlett-Packard
    driver: i915 v: kernel arch: Gen-4 process: Intel 65n built: 2006-07 ports:
    active: VGA-1 empty: none bus-ID: 00:02.0 chip-ID: 8086:2992
    class-ID: 0300
  Device-2: Logitech Webcam C300 type: USB driver: snd-usb-audio,uvcvideo
    bus-ID: 2-3:2 chip-ID: 046d:0805 class-ID: 0102 serial: <filter>
  Display: x11 server: X.Org v: 21.1.7 with: Xwayland v: 22.1.8 driver: X:
    loaded: modesetting alternate: fbdev,intel,vesa dri: crocus gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1440x900 s-dpi: 96 s-size: 381x238mm (15.00x9.37")
    s-diag: 449mm (17.69")
  Monitor-1: VGA-1 model: HP w17e serial: <filter> built: 2008 res: 1440x900
    dpi: 90 gamma: 1.2 size: 408x255mm (16.06x10.04") diag: 436mm (17.2")
    ratio: 16:10, 15:9 modes: max: 1440x900 min: 720x400
  API: OpenGL v: 2.1 Mesa 22.3.5 renderer: Mesa Intel 965Q (BW)
    direct-render: Yes
  Device-1: Intel 82801H HD Audio vendor: Hewlett-Packard
    driver: snd_hda_intel bus-ID: 2-3:2 v: kernel bus-ID: 00:1b.0
    chip-ID: 046d:0805 class-ID: 0102 chip-ID: 8086:284b class-ID: 0403
    serial: <filter>
  Device-2: Logitech Webcam C300 type: USB driver: snd-usb-audio,uvcvideo
  Sound API: ALSA v: k6.1.12-zen1-1-zen running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.65 running: yes
  Device-1: Intel 82566DM Gigabit Network vendor: Hewlett-Packard
    driver: e1000e v: kernel port: 1000 bus-ID: 00:19.0 chip-ID: 8086:104a
    class-ID: 0200
  IF: enp0s25 state: down mac: <filter>
  Device-2: Ralink RT2561/RT61 rev B 802.11g vendor: D-Link System DWA-510
    Wireless G driver: rt61pci v: 2.3.0 bus-ID: 07:04.0 chip-ID: 1814:0302
    class-ID: 0280
  IF: wlan0 state: up mac: <filter>
  Local Storage: total: 428.56 GiB used: 10.62 GiB (2.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WDS120G1G0A-00SS50 size: 111.79 GiB block-size: physical: 512 B
    logical: 512 B speed: 3.0 Gb/s type: SSD serial: <filter> rev: 1000
    scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 vendor: Hitachi model: HDS721032CLA362
    size: 298.09 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: A39C scheme: MBR
  ID-3: /dev/sdc maj-min: 8:32 vendor: Samsung model: HM020GI
    size: 18.68 GiB block-size: physical: 512 B logical: 512 B speed: 1.5 Gb/s
    type: N/A serial: <filter> rev: 0-06 scheme: MBR
  ID-1: / raw-size: 289.29 GiB size: 283.68 GiB (98.06%)
    used: 10.62 GiB (3.7%) fs: ext4 dev: /dev/sdb1 maj-min: 8:17
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/sdb2 maj-min: 8:18
  Src: lm-sensors+/sys Message: No sensor data found using /sys/class/hwmon
    or lm-sensors.
  Processes: 147 Uptime: 29m wakeups: 0 Memory: 5.78 GiB
  used: 1.82 GiB (31.5%) Init: systemd v: 253 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 Packages: pm: pacman pkgs: 988
  libs: 260 tools: yay Shell: Bash v: 5.1.16 running-in: qterminal
  inxi: 3.3.25

What have I to do?

Hello and welcome to the :enos: forums.

I see that you’re using the zen kernel on a pretty old Pentium D laptop with integrated graphics. I would like to suggest you try the LTS kernel because LTS has more backward compatibility than the ZEN kernel.

As a side note, how old is that laptop?

Welcome to EndeavourOS. I was going to ask something similar, I have an old MacBook from 2012 which my main computer, and I have an old MacBook from 2011. I was using the 2011 as a fun one to see what I could do and what not and I tried the zen kernel on it since I didn’t know much about it. When it had that kernel installed the screen would go out a lot. I chalked it up to my system not being able to handle this kernel since it is designed for performance. I had no issues with that computer running the standard kernel, never tried the LTS one though. Have you tried other kernels @zygarte ?

it has a Pentium 4 double core, GPU, intel 965, 256 MB

I’m using default kernel from usb media, I had to install lxqt, because xfce has some gpu issues and that bug is more likely to happen

Kernel: 6.1.12-zen1-1-zen

it says so you may have selected this in addition, at the initial install process.What will result in booting zen per default while main kernel is also installed as second option in boot menu.

But same a the posters before I would suggest to use LTS Kernel and may try to switch to legacy Mesa package too mesa-amber as we see GPU related issues…

Easiest way to switch your kernels is to use akm application provided by :enos: team.


I tried, core, zen an lts. three times display off, YOUR SESSION WILL BE TERMINATED

How I can to switch to legacy Mesa package?

mesa-amber is the legacy Mesa package which includes the classic (non-Gallium3D) drivers for older hardware:

simply install it and replace default mesa:
sudo pacman -S mesa-amber

1 Like

Did you restart the system after installing the kernel?

Yes, same bug every time

With mesa-amber, the bug happens again

i bet this is not a bug looks more like some hardware issue.

something like this:
sudo dmesg -rl warn,err,crit | eos-sendlog
may would hint on any issues related

I got this:

<3>[ 0.533092] ACPI BIOS Error (bug): _SB.PCI0._OSC: Excess arguments - ASL declared 5, ACPI requires 4 (20220331/nsarguments-162)
<3>[ 0.533233] ACPI BIOS Error (bug): Failure creating named object [_SB.PCI0._OSC.CAPD], AE_ALREADY_EXISTS (20220331/dsfield-184)
<3>[ 0.533245] ACPI Error: AE_ALREADY_EXISTS, CreateBufferField failure (20220331/dswload2-477)
<3>[ 0.533255] ACPI Error: Aborting method _SB.PCI0._OSC due to previous error (AE_ALREADY_EXISTS) (20220331/psparse-529)
<4>[ 0.581465] pnp 00:07: disabling [io 0xf800-0xf81f] because it overlaps 0000:00:1f.0 BAR 13 [io 0xf800-0xf87f]
<4>[ 0.581472] pnp 00:07: disabling [io 0xf820-0xf83f] because it overlaps 0000:00:1f.0 BAR 13 [io 0xf800-0xf87f]
<4>[ 0.581477] pnp 00:07: disabling [io 0xf840-0xf85f] because it overlaps 0000:00:1f.0 BAR 13 [io 0xf800-0xf87f]
<4>[ 0.581481] pnp 00:07: disabling [io 0xf860-0xf87f] because it overlaps 0000:00:1f.0 BAR 13 [io 0xf800-0xf87f]
<4>[ 0.582521] pnp 00:09: disabling [mem 0x000cb000-0x000e3fff] because it overlaps 0000:00:02.0 BAR 6 [mem 0x000c0000-0x000dffff]
<5>[ 14.202930] systemd-journald[289]: /var/log/journal/34d4252dcf0541279402c642c24cb01b/system.journal: Montonic clock jumped backwards relative to last journal entry, rotating.
<3>[ 21.028720] mei_me 0000:00:03.0: wait hw ready failed
<3>[ 21.028731] mei_me 0000:00:03.0: hw_start failed ret = -62
<4>[ 21.028741] mei_me 0000:00:03.0: H_RST is set = 0x80000015
<3>[ 23.162036] mei_me 0000:00:03.0: wait hw ready failed
<3>[ 23.162051] mei_me 0000:00:03.0: hw_start failed ret = -62
<4>[ 23.162064] mei_me 0000:00:03.0: H_RST is set = 0x80000015
<3>[ 25.295355] mei_me 0000:00:03.0: wait hw ready failed
<3>[ 25.295369] mei_me 0000:00:03.0: hw_start failed ret = -62
<3>[ 25.295377] mei_me 0000:00:03.0: reset: reached maximal consecutive resets: disabling the device
<3>[ 25.295381] mei_me 0000:00:03.0: reset failed ret = -19
<3>[ 25.295385] mei_me 0000:00:03.0: link layer initialization failed.
<3>[ 25.295389] mei_me 0000:00:03.0: init hw failure.
<3>[ 25.295481] mei_me 0000:00:03.0: initialization failed.
<4>[ 26.158924] platform regulatory.0: Direct firmware load for regulatory.db failed with error -2
<4>[ 26.612027] usb 2-3: Warning! Unlikely big volume range (=6144), cval->res is probably wrong.
<4>[ 26.612036] usb 2-3: [5] FU [Mic Capture Volume] ch = 1, val = 1536/7680/1
<5>[ 55.628636] systemd-journald[289]: /var/log/journal/34d4252dcf0541279402c642c24cb01b/user-1000.journal: Montonic clock jumped backwards relative to last journal entry, rotating.
<3>[ 584.529444] i915 0000:00:02.0: [drm] ERROR failed to set rcs0 head to zero ctl 00000400 head 01403c94 tail 00000000 start 00305000
<3>[ 8799.219989] i915 0000:00:02.0: [drm] ERROR failed to set rcs0 head to zero ctl 00000400 head 0e40217c tail 00000000 start 00305000

The top most, “Excess arguments - ASL declared 5, ACPI requires 4”, indicates the BIOS is old. Can you search to see if a new bios is available for this machine/laptop?

A freebsd user fixed this several years ago, but went way beyond what most users could do with patching the bios.

I cannot upgrade bios, my pc is an old hp small form factor 7700, its web doesn’t have a possible upgrade.

Furthermore, “reset: reached maximal consecutive resets: disabling the device”, I think that is the event of bug, because it happens after the third time when the screen has a refresh, and if I delete the saved monitor config, every time that screen goes black, before session is terminated, I got a warning of lxqt-monitor-config

I just want to say that the title of your post is highly annoying to me. We’re thankful you are giving us a try and it’s a pity you encounter these bugs.
Even though you probably intended it to be a title with some humour in it, since you are a first-time poster on this forum, this doesn’t sit well with me.

EndeavourOS is led by a couple of enthusiasts surrounded by a very friendly and helpful community. NONE OF US is paid to develop this distro or to help you.

Project leader and founder of this marvellous distro