Webcam doesn't work with Zoom

Hello all

My webcam stopped working with Zoom yesterday. The light indicating the webcam being on, is lit but I have no image.
Webcam works fine with Google Meet, and other applications, just on Zoom it doesn’t work, and this behavior started yesterday.
All ideas on how to resolve this would be very nice.

My inxi is here

What else changed yesterday?

Did you change any settings in Zoom?

No other changes that I know of. Only thing I have done so far is updating the system.

I have not changed any settings in Zoom.

That’s a change. Look at which packages you updated, and/or try reverting back to yesterday’s state e.g. using ALA.

EndeavourOS has a helper for that too :grin: Try eos-shifttime for reverting (and/or read our wiki about the choices…)


Zoom is only in AUR that I know of, so eos-shifttime does not work with that. Will check ALA

eos-shifttime is just a shortcut to the ALA - so if it’s AUR I think you’re SOL on that path! Sorry - not a zoomer, so I didn’t think to check that!

You could see what the PKGBUILD says, and perhaps an earlier version is on wherever it pulled from…

I need zoom for classes, they are all on zoom these days. Not sure which one is worse, MS Teams or Zoom.

Makes sense - just that I’m not taking any classes at this point in my senior existence! If I couldn’t pass the exam at the start of the classes, I wouldn’t do better later :grin: Short term memory is REALLY short these days…

Well, I figured to get my masters while covid was running around… even if I am a family man (just got 41)

@olividir have you tried the flatpak? Might have some luck there if the aur is being iffy

Haven’t even set up flatpack support. Will check it out, thank you

Zoom wasn’t updated yesterday so there’s no point in downgrading it.

Check which packages you updated by running paclog or looking in /var/log/pacman.log.

Well, looking through the paclog doesn’t reveal anything significant, nothing other than the regular updates. The only thing I did install shouldn’t affect Zoom. Installed cuda cudnn cuda-tools. I don’t think the dependancies for these should affect Zoom

I think I said this before: updates are changes to the system.

You could try to narrow it down to a particular update, or roll back to a previous set of packages, or just keep going.

It could also be a bug in Zoom 5.10; I’ve seen reports of the webcam stopping after the first use and requiring an exit+launch of Zoom to start working again.

Another option, given you’re doing a Masters, is that your institution will have technical support personnel who are paid to help students fix their technical issues.

Yes, that worked on monday for me, but since then, that method has stopped working.

I am not tech savvy enough to be able to narrow the problem to a specific update of a package or packages.
I have removed orphans, but I haven’t restarted yet. I want to be sure I have a full back-up of my stuff before I do that.

Unfortunately the institution I am studying at does not really rely on Linux, excep maybe Ubuntu. I personally think it is a very long shot, but it might be worth a try.

They’re paid to help. People on this forum are not. So, please do ask them.

Also, you could try downgrading the packages you updated before the problem started.

I know, but this is a small University which has EVERYTHING in Windows.
I also know I am more likely to get help here than there. I will however ask them tomorrow if they can help.

1 Like

As the webcam works with other apps, I’d do this:
yay -R zoom
^^ uninstalls zoom
Then try opening a zoom link; it should throw an error message, but attempt to open the link in the browser window, And usually has a link in that saying Start in Browser.
The browser then opens the zoom window internally and asks for permission to use the Mic and Camera…and this works.
I’ve been there and done that; zoom is rubbish on Linux.

:clap: :clap: :clap:
No arguments here.
I’ll mark it as a solution.

1 Like