Wayland woes

Been playing around with Qtile for most of the week. When I tried to login to Plasma wayland, I get a black screen and a flashing mouse cursor, anyone else seeing this?

Gnome wayland launches OK, though emacs segfaults and brings it down like a house of cards :smiley:

What about qtile Wayland?

Also doesn’t work, all I wanted to do was check if my emacs compile (with pgtk - pure gtk) worked under wayland, was running Plasma wayland until last week.

Dec 18 18:31:43 xircon-w6567sz systemd-coredump[1220]: Process 1197 (kwin_wayland) of user 1000 dumped core.
                                                       Found module KWinWaylandDrmBackend.so with build-id: fe22841d6e33bc5b039b52a9f92095efd4bc88b2
                                                       Found module libwayland-cursor.so.0 with build-id: 79d7e67af210407c2afe92ba8c189c8648a6474c
                                                       Found module libQt5WaylandClient.so.5 with build-id: c14a9317925fb7c8b54f7f558e0c82916311bdfe
                                                       Found module libKF5WaylandServer.so.5 with build-id: 1b384240b8c0ac0f062c677a5befc11ac13715f3
                                                       Found module libwayland-client.so.0 with build-id: 0a237f2fd096bada4ca381eec5d64474c4078be4
                                                       Found module libwayland-server.so.0 with build-id: 645526447334b85a6f4bf5a8b37737b27696365f
                                                       Found module libKWaylandServer.so.5 with build-id: 1f61370a3a2a90c808a5f244cb71d1bdee182bcc
                                                       Found module libKF5WaylandClient.so.5 with build-id: e507c814b8f28253281208693c91d5ddba8a5d80
                                                       Found module kwin_wayland with build-id: 2bf17de82c8dc784812d07d84644789ae02a681b
                                                       #15 0x0000560d95bead7e n/a (kwin_wayland + 0x8dd7e)
                                                       #18 0x0000560d95b878cb n/a (kwin_wayland + 0x2a8cb)
                                                       #20 0x0000560d95b882ce n/a (kwin_wayland + 0x2b2ce)

Are you running the propriertary Nvidia drivers by any chance?

No, Intel:

  Device-1: Intel 4th Gen Core Processor Integrated Graphics driver: i915
    v: kernel
  Display: x11 server: X.org driver: loaded: modesetting
    unloaded: fbdev,vesa resolution: <missing: xdpyinfo>
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4600 (HSW GT2)
    v: 4.5 Mesa 21.3.1

Rolled back to 13th - wayland working (and my emacs isn’t pgtk as when I kill Xwayland, emacs dies with it :cry: ).

Going to re-update and forget about wayland for a while, will try again in a couple of weeks.

I hear people have more problems with Wayland than I hear people praising it lol