Wayland with nVidia?

Well, I updated to Gnome 40 & I must say that I’m liking it quite a bit. Did some editing on the metadata.json files on a couple of the extensions I really want (ask me if you want to know how). But, I wanted to try Wayland to see the progress…In short, editing the GDM files to allow a Wayland start, I still get:

org.gnome.Shell@wayland.service: Control process exited, code=exited, status=2/INVALIDARGUMENT

Not sure what the invalid argument is–have looked through the Arch Wiki & Googled the problem…not seeing an answer. I wanted to post here first before going to the Arch Forums…Thought I’d get answers with “less” flack here :slight_smile:

would need first to see what you already configure to try start wayland on NVidia :wink:

I’m not entirely sure this is related, but it might help point you in the right direction?

It produces the same error message you have provided.

Yes—I’ve been there & started the KMS early with a kernel line—no joy. Modified the gdm-custom.conf in /etc/gdm to include wayland=true & worked through the system.d files as per the Wiki. I’m banging my head on this one.

there is this news

Thanks for the info!!!