Wayland not scaling correctly

I normally run KDE Plasma using X11 because it comes defaulting to X11 on install so I figure there are good reasons. My system uses a 4K UHD display. So I use the UHD resolution and a 200% scale factor so it acts like a FHD 1080P monitor, but capable of 4K graphics/videos if the app is capable.

I keep trying to test Wayland to see where it stands and currently I have 2 areas where it fails.

  1. SDDM scaling. with X11, I can Apply Plasma Settings in the Login Screen (SDDM) System Settings and the login screen will be sized to 200% so it’s readable on the UHD screen. However, with Wayland. The Apply Plasma Settings has no effect.

  2. My video player (MythTV frontend) scales 1080p content correctly with X11 to full screen, but not using Wayland.

I don’t know what the issue is here but have you tried loading X11, setting the scaling, applying the change to SDDM and then switching to wayland?

That was a clever workaround. With the 200% scaling in X11 and SDDM. I installed the plasma-wayland-session. I logged out and this time selected Wayland and logged back in. The screen was not scaled at this time so I changed the scaling from 100% to 200%. The mouse cursor also needed some adjustments. But mostly it worked. Even on Reboot, it had the scaled up SDDM screen.

It would be nice if the developers could fix this but the workaround is usable until…


1 Like

I also found a workaround for my 2nd item. mythfrontend has to be run with an option --platform xcb.