Wayland Login Loop & Possible Other KDE Hiccups

Using an AMD GPU (6950xt, stock), so the given Nvidia fixes don’t apply.

Had to perform an offline installation (which I believe may be the culprit), but the initial startups on Wayland worked fine. Now, however, I get kicked to the login screen instead of logging in immediately, and while I can log in if I change things over to x11, while wayland is selected on the screen, the console causes the screen to flash black for a few seconds and then return to the login screen. Logging in is impossible from that screen.

I’ve tried clearing my cache, config, and local directories, but this resulted in no change.
Also tried switching the display manager, and using only one monitor.

Installing more KDE components fixed the hibernation freezes and all the segfaults I found.

If anyone’d like more information from me, then please also let me know how to grab/format that/those, as I’m still somewhat shaky with linux as a daily driver.

Further information:
Using an MSI MAG Tomahawk x670E motherboard with 64GB RAM (should be most recent BIOS, has had some issues but is freshly back from service), CPU is a Ryzen 5 7600.

Welcome to the forum.

This is likely the cause, as your current predicament sounds similar to what is described in this video:



Basically, you need to make a backup of your .config and .local directories, delete the currents, then log out and try to log in. It would be better to try this from the tty.

Tty doesn’t appear to be accepting any inputs, I’m just getting a flashing cursor on a black screen. I’ll see what I can do with what is working.

Update: Wiping local as well did not work, however, I can now get to (still unable to use) tty from the login screen.

Okay, well, try doing it from the desktop of x11.

You should do both from x11. Or better yet, use your live cd/usb.

Used the live USB to clear out config and local, also no change.

I should note that by default I am doing anything here in X11, trying for Wayland won’t get me past the login screen.

Unless someone else can find you a solution, I’m all out, since this isn’t an Nvidia issue.

However, please note that unless you are using one of the Wayland window managers (Hyprland in particular), there is currently no actual benefit to using Wayland.

If it is that KDE6 itself is also giving issues, even on x11, then you have plenty of choices to use for now - KDE6 is new, and with newness comes imperfections.

All I can say is, try KDE6 Wayland again in a few months.