Waking system after suspend - does not ask for password - How can I change this?

I installed eos with gnome.
On debian when waking the os from suspend user is asked for password.

How can I achieve the same with ose?
Thanks.

Hi wisdomlight,
Right-click on the desktop > settings > power options.

I am not home right now but it’s definitely in the settings. I disable that because I’m lazy.

With XFCE it is in the Power Manager settings:

Thank both @mbod @vgaStudio
I am on GNOME - and there seems to be no Power Manager - but there is the Privacy > Screen Lock which suggest that the Automatic Screen Lock is on
But still there password is not required to unlock the screen.
Attached are two screen shots


Hello again wisdomlight,
on the above post, your first/top image (Privacy) is the correct one.

If you are not asked for a password upon “waking up” the system, then check your user account (Settings > Users) and see if it is set to automatic login?

Have you checked the gnome help page for this issue?
https://help.gnome.org/users/gnome-help/stable/privacy-screen-lock.html.en

Hi @vgaStudio
Thanks for you reply.
In Privacy> Screen Lock > Automatic Screen Lock is on
In Power > Automatic Suspend = On
An Settings > Users > Automatic Login = Off

Still the machine does not ask for my password when waking from suspend.

In your second image (Power) try turning
Automatic Suspend to off

Pudge

hi @Pudge
changed Setting > Powre > Automatic Suspend to off
logged out logged in
suspend - wake machine - password not requested

Solution was found.
changed display manager from lightDM to GDM.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.