VS Code won't open properly on fresh endeavour install


I recently made the switch from Mint to Endeavour. Only problem so far is that VS Code gets stuck on a blank welcome screen. I installed using sudo pacman -S code, and these are my system specifications: https://clbin.com/nbobZ.

This is all I get when I run it. I’ve tried running it from terminal using “sudo code”, “code .” and all combinations of those, with the same result. Same if I try not running it from terminal. This is what it looks like:

I also tried installing endeavour on my laptop to see if it worked there. My laptop has comparatively similar hardware, except it doesn’t have a NVIDIA GPU. On my laptop it worked out of the box.

This makes me suspect it has something to do with the GPU, however I’ve tested and installed the NVIDIA drivers with no problem so I’m at a loss.

Anyone have any tips?

In AUR it is present as visual-studio-code-bin.

For this,

yay -S visual-studio-code-bin.

Welcome @tofadle - Great choice.

I tried installing using yay now and unfortunately I get the same result

I had found this in Arch Linux Wiki.


Also, if you want open-source modification of it, then it is present as vscodium-bin .

One more thing, sometimes due to mismatch in version of electron, vscode fails to work.
Full system upgrade is solution for this issue.
Or older version can be temporary workaround for this, until new updates are pushed.

Welcome to Endeavour! :rocket:

try running

code --disable-gpu

Some clarification on the different versions.

1 Like

Yes!! This did it. Thanks a lot!

1 Like

Hadn’t you quoted same version of vscode twice ??

Thats me minus coffee :+1:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.