Vorta fails to start | python problem?

Hey dear community!

Today I tried to start vorta but this happened:

[jannisf@t480s ~]$ vorta
Traceback (most recent call last):
  File "/usr/lib/python3.11/importlib/metadata/__init__.py", line 563, in from_name
    return next(cls.discover(name=name))
           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
StopIteration

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/bin/vorta", line 33, in <module>
    sys.exit(load_entry_point('vorta==0.8.12', 'gui_scripts', 'vorta')())
             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/bin/vorta", line 22, in importlib_load_entry_point
    for entry_point in distribution(dist_name).entry_points
                       ^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/lib/python3.11/importlib/metadata/__init__.py", line 981, in distribution
    return Distribution.from_name(distribution_name)
           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/lib/python3.11/importlib/metadata/__init__.py", line 565, in from_name
    raise PackageNotFoundError(name)
importlib.metadata.PackageNotFoundError: No package metadata was found for vorta

I found this on AUR:

A reinstallation of vorta fixed it.
Must happened because of a python package update.

Some packages still tried to use a old python version.
See pacman -Qoq /usr/lib/python3.10

A reinstall did not fix it for me, same error.

This is my output:

[jannisf@t480s ~]$ pacman -Qoq /usr/lib/python3.10
tlpui
vorta

My system is up to date.

Is there anything I can do except waiting for a fix?
I cant code :')

Thank you very much!

Try a clean build.

1 Like

So I assume doing

yay -Rsu vorta && yay -S vorta

results not a clean build? :sweat_smile:

No, it will use the pre-existing source tree.

Example using nwg-shell:

yay nwg-shell
4 aur/nwg-shell-wallpapers 1.1-1 (+1 0.02) (Installed)
    nwg-shell wallpapers package
3 aur/nwg-shell-config 0.4.20-2 (+1 0.02) (Installed)
    nwg-shell configuration utility
2 aur/nwg-shell-git r338.c32a2e3-1 (+0 0.00) 
    nwg-shell meta-package, installer and updater - development version
1 aur/nwg-shell 0.4.3-2 (+6 1.07) (Installed)
    nwg-shell meta-package
==> Packages to install (eg: 1 2 3, 1-3 or ^4)
==> 1
AUR Explicit (1): nwg-shell-0.4.3-2
:: PKGBUILD up to date, skipping download: nwg-shell
  1 nwg-shell                        (Build Files Exist)
==> Packages to cleanBuild?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> a
1 Like

Ok i figured it out by reading the messages like a real linux aspirant! :smiling_face_with_tear:

[jannisf@t480s ~]$ yay -S vorta
AUR Explicit (1): vorta-0.8.12-1
Sync Dependency (7): python-dateutil-2.8.2-5, python-setuptools-1:67.7.0-1, python-peewee-3.16.2-2, python-secretstorage-3.3.3-2, python-pyqt5-5.15.9-2, python-llfuse-1.4.2-2, python-appdirs-1.4.4-8
Sync Make Dependency (1): python-pip-23.1.2-1
:: PKGBUILD up to date, skipping download: vorta
  1 vorta                            (Build-Dateien sind vorhanden)
==> Pakete für neuen Build?
==> [N] Keine [A]lle [Ab]brechen [I]nstalliert [No]nicht installiert oder (1 2 3, 1-3, ^4)
==> a

Thank you! :heart:

Is clean build?

No, its new build.

But may be the same meaning there.
I mean it has to be a “new build” because I’m building right now.

I think the translation is not very clear there.

“Pakete für neuen Build?” is not a real sentence.

I mean what kind of question is “packages for new build?” with the answers “yes” and “all”?

For beginners like me I’d like something as:
“Which packages shall be build from scratch?”
“Welche Pakete von Grund auf neu bauen?”

1 Like

The wonders of language :rofl: I can barely speak gibberish most days!

1 Like

So that I may be able to understand what happened.

Why did this do the trick?

For my understanding, if the packages from which I build are altered, they have to be delivered when I type

yay -Syu

But now there was no update, but with the action above I forced yay to get the packages it already had again.

Why did this solve the problem?

It is an AUR package, it’s source is in ~/.cache/yay/, in the vorta directory it has already built some packages against python3.10, it does not “recognise” this as a problem, the problem is that we now are on python 3.11 and all the libs are in a new directory tree.

It will only rebuild everything on a cleanBuild, so it fails because it cannot find all the correct paths and resources it needs.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.