Volumeicon discard in xfce4

I want the little volumeicon in the status tray plugin.
So i put the volumeicon command in the session and startup-application autostart.
After reboot and starting xfce4 (autologin) volumeicon started and was immediately discarded.

Run the command in terminal to get error messages.

Welcome to EnOS’ forum @8087!

Won’t adding the PulseAudio Plugin to the panel work?

No wont, it takes too much space in the vertikal deskbar

there is no error message in the terminal, but if i quit the process with strg-c or close the terminal the volumeicon disappears in the systray.
otherwise i start volumeicon in the xfce4menue (run app) then the volumeicon remains in the
systray. this is ok. in mx-distro the behavior of volumeicon in autostart is correct.

Volumeicon stopped working since pipewire replace pulse audio, you can just pin to dashboard the pulseaudio application in the startup menu and choose a personal icon by edit the pinned application

taskbar

one year ago that distro was quite better, now i am not able to autostart volumeicon, ufw.service (gufw resets after reboot in off-mode, but tlp works fine.
frustrating improvments…

For ufw it worked all the time, the latest iso apollo have firewalld on board by default, you can untick it during calamares setup, and after install ufw and gufw run this command :
sudo systemctl enable --now ufw
And enable gufw via GUI, at reboot it should work.
For TLP, uhm latest EOS Apollo is shipped with upower, no more TLP needed.

Yes i did this exactly with ufw and switch gufw on but after reboot ufw status is inactive.
And with tlp.conf i get in a easy way a lower temperatur in my laptop and the fan switches off, then in upower default setting. the volumeicon problem is not so important i know, but ufw inactve is a security problem.

Strange that ufw is dead at startup, less than you enable iptables too!!!

What is the output of:

sudo ufw status

systemctl status ufw.service

?

Yes i got that message - have to enable iptables. and enable iptables service

after reboot:
#ufw status
Status: inactive
#systemctl status ufw.service
ufw.service - CLI Netfilter Manager
Loaded: loaded (/usr/lib/systemd/system/ufw.service; enabled; vendor preset: disabled)
Active: active (exited) since Tue 2022-05-10 17:42:24 CEST; 3min 42s ago
Process: 291 ExecStart=/usr/lib/ufw/ufw-init start (code=exited, status=0/SUCCESS)
Main PID: 291 (code=exited, status=0/SUCCESS)
CPU: 130ms

mei 10 17:42:23 echo systemd[1]: Starting CLI Netfilter Manager…
mei 10 17:42:24 echo systemd[1]: Finished CLI Netfilter Manager.

?could vendor preset may be a fallback after reboot?

I don’t think so.

On my system

sudo ufw status 
     Status: active

and

systemctl status ufw 
â—Ź ufw.service - CLI Netfilter Manager
     Loaded: loaded (/usr/lib/systemd/system/ufw.service; enabled; vendor preset: di>
     Active: active (exited) since Tue 2022-05-10 17:33:22 CEST; 19min ago
    Process: 296 ExecStart=/usr/lib/ufw/ufw-init start (code=exited, status=0/SUCCES>
   Main PID: 296 (code=exited, status=0/SUCCESS)
        CPU: 198ms

But then I haven’t enabled iptables.service

All I did:
sudo ufw enable
and
sudo systemctl enable --now ufw

First i tried it without iptables.service, but i got invitation to enable it…
it seems that the service is running but gufw forgot it to switch on after reboot

this is only the default status after installing it.

About volumeicon:

it is not updated since 2015 :wink:
0.5.1

And is not installed on EndeavourOS per default as far as I know.

Start and enable ufw.service to make it available at boot. Note that this will not work if iptables.service is also enabled (and same for its ipv6 counterpart).

https://wiki.archlinux.org/title/Uncomplicated_Firewall

Ok, but last year it works. @badplugin wrote s.th. pipewire didnt support this good old thing in pulseaudio. its a pity

i have removed firewalld, lightdm and disable iptables.service and now ufw autostarts.
What was it?

yea ufw does not work when iptables service is running as they are overlap each other ?