Vivaldi 4.1.2369.11-1 broken on ONE of my systems... how can I debug this?

Hi, I have just updated Vivaldi browser to last version (from community repo) and it is just broken. White screen, no GUI, nothing… Reboot does not helps.
The version is 4.1.2369.11-1 and the ffmpeg-codecs is 92.0.4515.115-1
Downgrading to previous version resolves the issue. (Vivaldi 4.0.2312.41-1 and codecs 91.0.4472.114-1)
Just letting you know… curious if it is my system or if it occurs for others ?

UPDATE: On a second laptop with exactly the same configuration and applications (with base EOS Plasma) the new Vivaldi is working without issue. So… it’s something on my system.
Any idea how to try to debug this and understand what happen here ?

I’m merely guessing, but sounds like something in your vivaldi configs is not OK.

One simple way to test this idea is to create another user and run vivaldi with that user. If it works, then the configs of your account for vivaldi are somehow broken.
Then you’d have the alternatives to delete old configs, or try to debug the configs somehow in vivaldi’s config system.

BTW vivaldi works OK also here. :smile:

1 Like

Well, no… Doesn’t work. Login with a new user results in the same behaviour: the 4.0 version works but not the new 4.1
Now I have on my system the 4.0 version and a flac in pacman to ignore update… and I have installed also the snapshot version (from Herecura repo) which does not work either. This way I can upgrade the snapshot version and eventually it will work in a moment, so I’ll update the regular version.
That’s all I can think about at the moment as workaround.

Is any vivaldi related component missing from the other machine? Have you fully updated both systems?

If nothing else helps, you could show journal around the moment when you start the failing vivaldi 4.1.
Something like:

  sudo journalctl --since "1 min ago"

My bet…

Computer 1 is running systemd-resolved

Computer 2 isn’t.

Test this:

sudo systemctl disable systemd-resolved --now

Relaunch Vivaldi.

There is (I hate to say “bug”, so will go with…) new feature in systemd 249 that breaks chromium based browsers :rofl:


It goes like this … during many, many more lines


Jul 28 21:29:50 pierre-latitude5500 systemd-coredump[7602]: [🡕] Process 7558 (vivaldi-bin) of user 1000 dumped core.

                                                        Found module with build-id: 54e0dba403a>
                                                        Found module with build-id: 00d395a>
                                                        Found module with build-id: 8>
                                                        Found module with build-id: 69bb>
                                                        Found module with build-id: 1a36dfc01>
                                                        Found module with build-id: ba85170c2>
                                                        Found module with build-id: 919597c477c9b>
                                                        Found module with build-id: 47761dc11>
                                                        Found module with build-id: 6fe3b6ece2c8>
                                                        Found module with build-id: ac40031740107>
                                                        Found module with build-id: 4a114f6a371>
                                                        Found module with build-id: d3d0ddf2f54f554>
                                                        Found module with build-id: e63600ab23b2f69>
                                                        Found module with build-id: 4b10444c1560eb>
                                                        Found module with build-id: f8d607153b2b31>
                                                        Found module with build-id: e58d34ab389d1b>
                                                        Found module with build-id: 2d70cff7b18>
                                                        Found module with build-id: 9a878e513c02>
                                                        Found module with build-id: 4df18bd1f1377>
                                                        Found module with build-id: 015ac6d6b>
                                                        Found module with build-id: f0fd7579e163a1>
                                                        Found module with build-id: 5314ec74654>
                                                        Found module with build-id: ac405ddd17>
                                                        Found module with build-id: c4ee4ad>
                                                        Found module with build-id: 86413f38be2>
                                                        Found module with build-id: 632a59ed7c>

And at the end: Jul 28 21:29:57 pierre-latitude5500 systemd[1]: systemd-coredump@4-7846-0.service: Deactivated successfully.

YES !!! That was the solution:
sudo systemctl disable systemd-resolved --now
Thanks @xircon

Not a good fix though, something is seriously wrong with the current version of systemd. I actually need systemd-resolved so I have downgraded systemd & systemd-libs to 248.3 so I can run cloudflare warp (it seriously improves page loads).

I agree. I am not sure if it is related but in this laptop (with the Vivaldi issue) I also have a VPN connection issue to one specific server, while in the other laptop where there is no Vivaldi issue I can connect to this server, from the same wifi network…
But more strange: both laptops are running the same systemd version, EOS up to date.
Another network mystery I guess… :man_shrugging:

1 Like

@xircon WOW… wait… not really fully resolved: I have rebooted and now I have no connection “Unable to set system DNS server” …

Back to square one… Vivaldi 4.0 and systemd-resolved enabled (I can live for now an older Vivaldi version but I need Internet) :innocent:

sudo downgrade systemd systemd-libs

Pick 248.3 from the list for both, then reboot. Add to ignorepkg.


Yes, I can do this… it’s just the other way around, the 2 workings options are:

  1. Downgrading vivaldi and keeping systemd up to date.
  2. Downgrading systemd and keeping vivaldi up to date.

For now I am with option 1. May switch to the other one tomorrow…

1 Like

I got this same issue after updating Vivaldi to 4.1 yesterday. I disabled the systemd-resolved kept my current systemd which is working for me at the moment.

So what does systemd-resolved really do? I read that it helps to resolve DNS for the local applications. Applications meaning stuff like vpns?


1 Like

I can confirm that vivaldi 4.1.2369.15 fixes this issue.

As I write, this new version is not yet in the stable repos, but it should be there soon. I was impatient, so I upgraded manually by editing the PKGBUILD for the current package.

Update: vivaldi 4.1.2369.15 is now in the stable repos.


Yep, this is fixed I just updated mine enabled systemd-resolved and loaded Vivaldi without any issue with that troublesome systemd version.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.