Virtualbox problem

Hello, since yesterday after EOS update Virualbox 7.0.18 stopped working. It fails to reinstall the extendet pack /err:The installer failed with exit code 1: VBoxExtPackHelperApp: error: The owner is not root: ‘/usr’/
Cannot start any VM err: /Windows XP’ has terminated unexpectedly during startup with exit code 1 (0x1)/

I tried a clean install of EOS-KDE on the second disk and exactly the same problem
Today I tried a clean install of Manjaro on a testing drive and exactly the same problem
A clean installation of Arch works Virtualbox 7.0.18 OK!

Please how to solve this on EOS? Wait for an update? VB was still working great in EOS at the weekend

This is a sign of alien/bad system administration.
What does this say?

stat /usr

Thanks say:

Soubor: /usr
Velikost: 86 Bloků: 0 I/O blok: 4096 adresář
Zařízení: 0,34 I-uzel: 310 Odkazů: 1
Práva: (0755/drwxr-xr-x) UID: ( 0/ root) GID: ( 0/ root)
Přístup: 2024-06-12 18:47:34.886060786 +0200
Změna obsahu: 2024-06-12 18:47:34.886060786 +0200
Změna i-uzlu: 2024-06-12 18:47:34.886060786 +0200
Vznik: 2024-06-06 11:48:09.963167344 +0200

Since root is the actual owner of /usr/, it seems this is a Virtual Box bug.
I don’t know if it is possible to downgrade Virtual Box to the previous version, but if it is possible, it would confirm or not if VB new upgrade is the problem.

Have you checked at VBox forum for similar error reports?

I’ve just installed virtualbox and there is no issue here. :man_shrugging:

stat /usr is root

1 Like

This morning after an update (kernel) Virualbox started working again. Thank you all for trying to help.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.