Virtualbox: Iso 2019-12-03, VMSVGA still not works

Linux hosts
VBox 6.1.0_RC1-135185 dev snapshot for the upcoming 6.1.0
VBox 6.0.15-135093 test build for the upcoming 6.0.16


With the setting VMSVGA the boot process still hangs. With VBoxSVGA (or the old VBoxVGA) it works.

I don’t think that will change as long as vboxguest modules are integrated in the image. To my knowledge with kernel 5.4.x this is no longer necessary.

but this is a upstream BUG and not related to EndeavouOS directly.

I have download & install the 2019.12.03 ISO yesterday without any problems.

This is a bugreport for a specific issue.

have you tried with Archlinux?

Logically, yes. Then more users should notice this (it has been in place from the very beginning). It would have to exit at least 1 bugreport. But…

vmsvga - nothing.
vboxvideo - nothing.
vboxguest - several, but just without the buzzwords vmsvga or at least vboxvideo or vmwgfx.

OK, Arch doesn’t have live images. :wink: But installed in a VBox-VM it should stand out.

E.g., in lubuntu-19.10-desktop-amd64.iso vboxguest is also integrated, this is also loaded. I can boot to the desktop with the VMWARE setting and choose different standard resolutions (no crooked windows, automatically this only works with VBoxSVGA). But the module vmwgfx is used.

So it can’t be a general VBox problem (or Canonical corrects it :smiley: ). On I haven’t found any matching tickets yet.


With 64 MiB or 32 MiB for the virtual GPU…works. Also with 256 MiB. And now also with 128 MiB (errors occur anyway, but at least also the desktop), without having consciously changed anything else. What? Coffee break.