Virtualbox installing Xfce4 by Deepin

Virtualbox is installing Xfce4 and not Deepin as i tried to do when marking this option during the process of installation, i have been doing this now for three times with the same results.

The first time the system was full (the command df -h was indicating 100%) and everything was unstable. This is not the problem now that it is just 68%.

The ISO i used the first time was the same i installed in my system but now i downloaded this ISO: endeavouros-2019.12.22-x86_64.iso which is smaller 1.6 GB

This system work fine in virtualbox … just it is Xfce4:

Captura de pantalla_2020-01-22_14-33-42

I have been trying to find if there is any button to switch to Deepin but there is nothing, not even a login section (yes, i created the user) and the system is coming up in English when i installed in Spanish.

Standard iso = Xfce if you in Virtualbox you can choose deepin by installing it…

because its a netinstaller.

vbox is awesome, you use a nvme , you can also emulate nvme, i believe is standard sata.

in vbox it does not directly demand lot space it can growth ofcourse…

After almost two hrs waiting it happen again … Xfce4.
It is Virtualbox, i already uninstalled it, i will try something else tomorrow, thanks.

virtualbox or xfce in virtualbox ? did installing a longtime to install ?

I had endeavouros/xfce4 installed in virtualbox, the one that was supouse to comes as Deepin but it comes later up as Xfce4 , then from inside this i installed again endeavouros hoping this time were possible to get Deepin but again … Xfce4.

Sorry, this is the best i can explain all this mess in my limited english – any way it do not works, i will try to find another sandbox. Thanks!.

other sandbox , virtual environment is more complicated then virtualbox… as like some other if you make a VM, some vm makes a disk so it need disk space.

in virtualbox it makes the disks, but not in full size. if you say 8gb but it does not start with 8gb depend what you install on vbox , if you use qemu and setup a disk it takes from start 8gb from disk.

but standard is the iso Xfce if its installed make sure in settings in virtualbox that the iso is unloaded or choose from start to load from disk. because in some cases does not stop the iso in vbox i gues, you have to look at the disk in settings of that vm and remove the iso to avoid load in and look if it runs again, the pic you showed is basicly a iso ? or i am confused :slight_smile:

No this PC doesn’t have any space disk. :pensive: :worried: :rage:

@Keos I think someone tried to point this out earlier, but maybe it got overlooked. There are two installers for EOS. One is always Xfce, the other is called the netinstaller which provides the option of installing other DEs, but you have to choose Online installation. If you are not seeing the option of choosing Offline or Online, then you are likely not using the netinstaller.

I hope this helps.

When you launch the live ISO and it boots up you have to click the box in the welcome screen that say’s start the installer. From there you select online go through the settings until you reach the desktop selections. Then you select Deepin and also Printing support for printers. All of the desktops are listed there.

if you 16gb in vbox does not make a drive out of the box on disk it is dynamic probably first install is round 8gb or 9gb… to see and experience is good to go infact.

Thanks for your interest in this matter, my friends, this was exactly what i did for now four times online installation, and of course DEEPIN … may i ask you if you tried to do this on your machines?. It looks to me that there is something wrong with virtualbox and Deepin, i already uninstall the whole thing, i should have tried another desktop to check if the problem were with deepin or … any way i’m tired …

Thank everybody.

Here the picture to help you to get it :

1- When you boot from your USB key live EOS you will see this windows so click on START THE INSTALLER :


2- Select the ONLINE Method then click OK and follow the setup from this Installer called CALAMARES


3- When You are at Package Selection Select the DEEPIN DE and continue


Knowing be patient depending your speed conexion, it could go from 10mn to more than 1h.
So if you see the % blocked at the same value for a while don’t worry it’s normal, so wait until the end.

Don’t forget to look at the website for INSTALL also the WIKI, you will find all what you need :

Enjoy it ! :rocket:


I don’t see the link with VirtualBox and the fact you got XFCE in spite of DEEPIN !!!
This could only comes from how You use Calamares the Net-Installer…

Something has to be wrong in the way you do cause I installed DEEPIN DE throw VirtualBox without any problems ! and I’m not the only one who did it !

Did you follow the Wiki about how to use VirtualBox ?

Did you check your ISO file md5sum after download ?

If you could show us a screenshot where you selected DEEPIN DE throw Calamares ONLINE ?

We are right, you boot on your EOS usb key live throw VirtualBox then when you are on XFCE by default you clicked on START THE INSTALLER and chosed ONLINE ?

Is it possible that @keos is rebooting virtualbox without removing the optical drive check mark so that it is just booting back up on the live ISO? I say this because i don’t think he is understanding how to use it. Therefore even though maybe he did install Deepin he is just booting back up on the live ISO because of the settings.

I’m wondering if he really setup correctly Vbox on how he defined the size of Storage !
From what I read on other post he has only 30Go HDD on his machine. I would be curious to know which size he gave to his Storage on his Vbox ?

It seems that he mixes the live XFCE install and the ONLINE one !!!

Yes i wonder too? Seems to be a lot of issues with instability which i attribute to not only the drive size but misunderstanding maybe and possibly the hardware. Definitely i believe the drive size and what is trying to be done is part of the issue. Not totally understanding is maybe another part of it. I don’t know how else to help? But if as he say’s he has installed Deepin numerous times it may be that it’s just booting back up on the live ISO and in fact it is actually installed?

Yep I didn’t think of this, it could be that he let the USB key plugged and then in spite to boot on the Deepin install, in fact he boot again on the USB key.

Just remove the usb key after install could be the solution !!!

1 Like

If he is in fact using a USB key? I was more thinking that if he is using a downloaded ISO file as i do then i remove the optical check mark in the settings or the actual iso file. I don’t usually installl in virtualbox using a USB key. I just download the ISO and launch from that. So either way that is what will happen. It will just boot off the live ISO.

A USB? i haven’t using any USB. Just downloaded the endeavourus in my system then installed virtualbox and got the iso into it following the indications … and it was all.

So @Keos, as you use directly the ISO downloaded, did you remove the optical check mark in the settings of the actual iso file as @ricklinux told ?

1 Like