Video issue on Gnome with amd 6800 + Nvidia

Hi, I just installed EOS on my new laptop, a Lenovo Slim 7 Pro X which has an AMD 6800HS processor and NVIDIA RTX 3050 graphics.

When I booted into the live iso, choosing the nvidia drivers option at boot, I was greeted by the xfce desktop and although the interface was way smaller than usual (hidpi issue?) it worked fine.

After installing (I chose the gnome desktop) however, this is what I see when boot finishes and the desktop loads.

I can’t even use the terminal, any idea what should I do to fix this video issue?

Unable to access Imgur for the pic - so what is the problem? :grin:

The problem is… corrupted display, I can’t even see what I’m doing - can you access the pic here?

Yup - and I can see where there is a problem! You mentioned Gnome - did you allow it to default to Wayland, or did you select an X session when logging in? If that is involved in your difficulties, it might let you work on the system while fixing it!

I simply enabled the auto-login option in the installer, so this is the first thing I see after booting finishes. I wouldn’t know how to choose a different session even if I wanted…

Never done that - didn’t think of that! Could be a problem :grin: I suspect that it IS dropping you into Wayland by default then, but I don’t know enough about how to bypass it. The long way is to reinstall WITHOUT the autologin, but that may not be necessary…

I hope someone who knows more (especially about nVidia!) drops by - all I know is what I have ‘heard’ about Wayland/nVidia interaction - mostly here. Do any of the console access keys work to induce visibility? Such as CTRLALTF3 for a full screen console… (F7 or possibly F1 with CTRL-ALT to return to the graphics). That might give you ‘access’ to allow recovery operations…

Not a nVidia user so I couldn’t be of any help for that.

However if you want to disable autologin you could login via tty and try to edit /etc/gdm/custom.conf.

Here is the section for enabling the autologin in GDM:

I guess you would need to remove those lines.

Here is how to get to tty by editing the Grub boot line, if you are using Grub:

The procedure is similar for systemd-boot as well. If you are not seeing your systemd-boot menu, you could bring it up by pressing left-shift (or perhaps esc also) while starting up your machine.


the problem is limitations with xorg or wayland. What resolution do you have it set for? I know nothing of wayland and the issues i have had with Nvidia I have been able to fix after a few days of hair pulling. Also you want to make sure of what driver is being used nvidia or novea in a tty try the command nvidia-settings also check if you have nvidia-dkms and nvidia-inst. but make sure your using nvidia drivers.

I booted to console as suggested by pebcak, then started nvidia-inst which reported this error message:

pcilib error reading sys/bus/pci/devices/0000:00:08.3/label: operation not permitted
nvdia card id 25e2

it then asked for my password and installed the driver. However when I rebooted the desktop was corrupted as before.

Out of curiosity I booted the live iso, first with the default option (I only saw the mouse cursor but the screen was black), then with the nvidia option (display was ok). Is there a way to achieve the same result on my gnome desktop?

Ok, solved. AMD graphics can be used by adding the amdgpu module to boot options (solution found here ).

Or, the official Nvidia driver can be installed and then you need to add these boot options: nvidia nvidia_modeset nvidia_uvm nvidia_drm

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.