Video file thumbnails not shown in nemo?

I’ve got a bunch of video files with thumbnails on an external hard drive and when I transfer them over (i.e. copy and paste) them to my video folder on my computer main drive the file transfer with no problems but the video thumbnail doesn’t appear for the file on my main computer drive. In Nemo ‘preferences’ under ‘view’ I have inherit thumbnails from parent ‘selected’ and files under 64-gig also set as default. The files are smaller than 500 meg in size and nowhere near the 64-gig limit, and still no thumbnail. Any solutions?

Rich :wink:

I can only say what works in Dolphin, possibly in other file managers.
The package ffmpegthumbs is missing: sudo pacman -S ffmpegthumbs

I re-installed ffmpegthumbs. . . .it was there in my file system. Still doesn’t show some thumbnails. It shows some on file transfers and others it doesn’t. Even when set to the 64-gig limit.

Rich :wink:

This is for Dolphin.

Try this one for Nemo:

Thanks, I tried it with arch’s file. . . still no solution.

Here’s what I’m referring to. . . .

rich :wink:

I am afraid I couldn’t be of more help.
It works fine on my end with thumbnails in Nemo so I don’t know what the issue might be.

@pebcak :ballot_box_with_check:

Can you post the contents of the /usr/share/thumbnailers directory. And also ~/.cache/thumbnails

What specifically are we looking for?
Screenshot from 2023-01-08 08-18-28
Screenshot from 2023-01-08 08-33-12

Rich :thinking:

There are reports from users that totem.thumbnailer and ffmpegthumbnailer.thumbnailer are conflicting thumbnailers.

totem.thumbnailer is used by nautilus file manager. If you don’t use nautilus, I suggest removing totem.thumbnailer altogether.

Here is what I recommend:

  1. First, move totem.thumbnailer to a different location (alternatively, you could create a copy of that file with a different name like totem.thumbnailer.backup so that you don’t lose that file)
  2. Delete totem.thumbnailer from /usr/share/thumbnailers/ (you can skip this step if you chose to move totem.thumbnailer to a different location in step 1, since the file won’t be there if you move it out of the directory)
  3. Delete the fail directory inside ~/.cache/thumbnails (rm -r ~/.cache/thumbnails/fail)
  4. Reboot and launch nemo.
1 Like

Deleted file totem.thumbnailer in user/share/thumbnailers. . . .this fixed the problem with the video files. . . now they have pictures. That did the trick. . . . Thankyou for you help. . . much appreciated.

Rich :smiley: