Vainfo & Others Broken by Installing Wrong Dependencies

Hi there,

I’ve been using EndeavourOS KDE for just a couple of weeks now and I seem to have messed up my graphics drivers/dependencies. I’m hoping I don’t need to just do a clean install “with lessons learned”, but it seems that might be the case.

I noticed that I could not get G-Sync/VRR to initialize on my monitor using X11, so I tried out Wayland, which with the latest 535 Nvidia drivers worked pretty well. Wayland still had other problems, so I went back to X11. This is when I noticed that the page at System Settings → About this System → More → Graphics → OpenGL (EGL) was broken saying “eglinfo tool crashed”.

I previously installed Lutris with the guide here to install the necessary 32-bit dependencies, and I think this may be around the time I messed it up by installing other 32-bit dependencies I actually didn’t need over time.

Running nvidia-inst produces:

2023-06-16 16:22:45: Info: Running: nvidia-inst v23-5
2023-06-16 16:22:45: Info: Command line: nvidia-inst
2023-06-16 16:22:45: Info: Selected mode: nvidia
NVIDIA card id: 2489
Fetching driver data from
2023-06-16 16:22:46: Info: Rename existing file /etc/X11/xorg.conf.d/20-nvidia.conf to /etc/X11/xorg.conf.d/
2023-06-16 16:22:46: Info: Removing packages: lib32-nvidia-utils

    pacman -Rs --noconfirm --noprogressbar --nodeps lib32-nvidia-utils
    mv /etc/X11/xorg.conf.d/20-nvidia.conf /etc/X11/xorg.conf.d/

==> NOTE: running the commands may take several minutes…

Root Password:
checking dependencies…
error: failed to prepare transaction (could not satisfy dependencies)
:: removing lib32-nvidia-utils breaks dependency ‘lib32-vulkan-driver’ required by steam
2023-06-16 16:22:52: Note: To have the changes in effect, you must reboot the computer.

and vainfo:

Trying display: wayland
Trying display: x11
libva error: /usr/lib/dri/ init failed
vaInitialize failed with error code 1 (operation failed),exit

I’ve collected the eos-logs, uploaded here

If you have any advice on what I should do to try and fix these things, or if I should just reinstall & avoid doing the same in the future, I’d really appreciate it!

1 Like