USB stick grub contents

trying to install EndeavourOS on a new computer.
I am able to install Manjaro.

Some of the contents of grub on the Manjaro install stick are:
driver=free nouveau.modeset=1 i915.modeset=1 radeon.modeset=1
(some manjaro specific arguments) quiet systemd.show_status
and more.

Wondering if something from above can be added to the EndeavourOS install grub to allow me to install EOS


SOLVED: with link from joekamprad by notification of ricklinux

Hello @garybean
Have you tried installing EndeavourOS? What is the output of inxi -Fxxxco You may have to install inxi

Honestly speaking, I’m not understanding what issue are you facing? Can you elaborate?

1 Like

can be set manually on bootmenu if you need them…

From the perspective of a limited knowledge linux user, the issue I face is that USB sticks loaded separately with an ISO of Manjaro and one of EndeavourOS, on the same computer, one installs and the other cannot. I am not able to reach the opening GUI install screen with EOS.

Thusly I conclude it is possible to install Linux on my computer, as is, based on what is included in the Manjaro install ISO. The technical knowledge used to create what exists on those install ISO’s is beyond my experience.

(hope the above clarifies my concern better)

What is installed on the computer currently? Do you happen to know your hardware? Is it possible to boot on Manjaro and post the output of inxi -FGz at least. If inxi isn’t installed you can install that with.

sudo pacman -S inxi

System: Host: ASUS-manj Kernel: 5.4.18-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.17.5 Distro: Manjaro Linux
Machine: Type: Desktop Mobo: ASUSTeK model: GL10DH v: 1.0 serial: UEFI: American Megatrends v: GL10DH.301
date: 10/01/2019
CPU: Topology: 8-Core model: AMD Ryzen 7 3700X bits: 64 type: MT MCP L2 cache: 4096 KiB
Speed: 3594 MHz min/max: 2200/3600 MHz Core speeds (MHz): 1: 3592 2: 2028 3: 2053 4: 2051 5: 2052 6: 3975 7: 2104
8: 2114 9: 2051 10: 2053 11: 2053 12: 3589 13: 2051 14: 2054 15: 3605 16: 2053
Graphics: Device-1: NVIDIA TU117 [GeForce GTX 1650] driver: nvidia v: 440.59
Display: x11 server: X.Org 1.20.7 driver: nvidia resolution: 1920x1080~60Hz
OpenGL: renderer: GeForce GTX 1650/PCIe/SSE2 v: 4.6.0 NVIDIA 440.59
Audio: Device-1: NVIDIA driver: snd_hda_intel
Device-2: Advanced Micro Devices [AMD] Starship/Matisse HD Audio driver: snd_hda_intel
Sound Server: ALSA v: k5.4.18-1-MANJARO
Network: Device-1: Realtek driver: rtw_pci
IF: wlp7s0 state: down mac:
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169
IF: enp8s0 state: up speed: 1000 Mbps duplex: full mac:
Drives: Local Storage: total: 1.84 TiB used: 9.21 GiB (0.5%)
ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKNW010T8 size: 953.87 GiB
ID-2: /dev/sda vendor: Toshiba model: DT01ACA100 size: 931.51 GiB
Partition: ID-1: / size: 38.23 GiB used: 8.37 GiB (21.9%) fs: ext4 dev: /dev/nvme0n1p6
ID-2: /home size: 134.53 GiB used: 811.4 MiB (0.6%) fs: ext4 dev: /dev/nvme0n1p7
ID-3: swap-1 size: 7.89 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-0
ID-4: swap-2 size: 15.62 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/nvme0n1p8
Sensors: System Temperatures: cpu: 37.4 C mobo: N/A gpu: nvidia temp: 28 C
Fan Speeds (RPM): cpu: 1500 gpu: nvidia fan: 26%
Info: Processes: 308 Uptime: 22m Memory: 7.77 GiB used: 1.70 GiB (21.9%) Shell: bash inxi: 3.0.37

Thanks @garybean
As i suspected you have a newer Nvidia Graphics card that is an issue booting on the ISO.
Here is a link to an nvidia enabled ISO from @joekamprad that you can try. It should work and when you use the online installer you can select nvidia drivers along with the desktop of choice and printing support. Let me know if this boots up for you.

Edit: Nice CPU by the way. I have the AMD 3800X

1 Like

the 65W TDP of the 7 3700X appealed to me

Yes i thought about it but i couldn’t resist so i went for the 105W 3800X

Edit: Also a nice video card to compliment that.

The 8 core 16 thread appealed to me as i already have an Intel 8086K 5.0 Ghz processor that is 6 core 12 thread. Works beautifully but the AMD will be far better.

am downloading the newer ISO. Had I a choice I would have went with an AMD GPU

I’m looking at the inxi output and i see you have an m.2 drive and another drive. I see two swap partitions of different size. Just trying to understand that?

Edit: Just curious about this entry.
ID-3: swap-1 size: 7.89 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-0

The only reason is because it ends with /dev/dm-0

Most m.2 partitions are /dev/nvme0np1 …p2 …p3 and so on

Okay i get it. It must be LVM as that what i read on a site.

Ya i went with a Gigabyte Radeon RX590 with 8 GB memory.

ID-3: swap-1 size: 7.89 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-0

was created by a Fedora install with guided install, now deleted

I have been contemplating if any of the AMD GPU’s are worth an additional investment (playing with price and what I really need in graphics performance, I do appreciate how the AMD cards work better with Linux)

ricklinux, thank you for the link, that ISO version installed perfectly


Glad that worked for you and the ID-3: swap-1 size: 7.89 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-0 just seemed weird to me in the naming of the device.

I didn’t realize you had installed anything prior but that makes sense now and i read something about it being LVM related which i haven’t used on my system. My m.2 drives always name /dev/nvme0np1 and so on… so i caught that right away. :thinking:

So just keep in mind that the you’ll need to use a nvidia enable ISO at least currently to install EndeavourOS. I’m not sure what the plan is for the future releases. Some of the newer Nvidia cards don’t boot properly without nvidia graphics. I also have a GTX 1060 which is the same issue. It is possible to get around that problem on mine if i use the onboard intel graphics and turn off the nvidia and then install nvidia after the install and turn it back on. But you don’t have that option with the AMD CPU. Hence why we needed to use the nvidia enable ISO thanks to @joekamprad.

1 Like