Usb headphone not auto switch when plugged in

I have got this Plantronics multimedia headphone. Sometime it does not get added into “volume control” when it is plugged into usb socket, especially now.
Is there way to refresh it so that it added into “volume control” so i can choose to use it to output sound instead of restart pc … i kind of like terminal cli to do it… like xrandr is a good one for monitor

thx

first thing i would check is jornalctl -f while plugging in the headset, mostly it will give some output, and this can hint on what it does if it work and what error if it does not work.

I used $lsusb, plantronics headphone did appears on the list. This device was working on this same os just yesterday. I unplugged it and when plugged it back, i can’t see the device in “volume control” option. , but it is listed in $lsusb.

$journalctl -f

  kernel: usb 3-1.5: new full-speed USB device number 6 using ehci-pci
  kernel: usb 3-1.5: New USB device found, idVendor=047f, idProduct=c014, bcdDevice= 2.46
  kernel: usb 3-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=0
  kernel: usb 3-1.5: Product: Plantronics .Audio 622 USB
  kernel: usb 3-1.5: Manufacturer: Plantronics
  mtp-probe[349194]: checking bus 3, device 6: "/sys/devices/pci0000:00/0000:00:1d.0/usb3/3-1/3-1.5"
  mtp-probe[349194]: bus: 3, device: 6 was not an MTP device
  upowerd[1146]: treating change event as add on /sys/devices/pci0000:00/0000:00:1d.0/usb3/3-1/3-1.5
  mtp-probe[349226]: checking bus 3, device 6: "/sys/devices/pci0000:00/0000:00:1d.0/usb3/3-1/3-1.5"
  mtp-probe[349226]: bus: 3, device: 6 was not an MTP device

I don’t want to login and log out or restart , hence i asked if there is command to “refresh” it, so that it is added in. or restart sound server ?

journal does not show anything failing, but also do not show audio connection at all.
you could try starting the module manually to see if this helps:
sudo modprobe snd-usb-audio

$ sudo modprobe snd-usb-audio
modprobe: FATAL: Module snd-usb-audio not found in directory /lib/modules/5.9.9-arch1-1

Can you pls explain to me the meaning of this ?

Can’t help it, no other soln, hence just restarte the laptop and it is back to good again.