USB 3.0 HDD NTFS not detected

Hello everyone

I just installed endeavoros, everything looks good. But I my external hdd is not detected with USB 3.0 port, while using USB 2.0 port no problem occurred.

My external hdd is using ntfs. I tried plug my USB flashdrive (exfat) with USB 3.0 port, and it’s working perfectly.

I hope anyone in this forum can solved my problem.

Try a different cable, a different port, and ideally on another system with USB 3.

Keep in mind that USB 3 can also be susceptible to electromagnetic noise, so if USB 2 works then that’s the fix.

Welcome to the forum @afacyber :partying_face::tada:

Is it a problem with detecting it or mounting it? Plugging it in run


You could also check it unlugged then plug it in and run

dmesg -w 

See if it shows the drive failing at connecting in the log. Maybe it will give some clue?

1 Like

Hello everyone

Thanks for all the responses and help

My external hdd is now detected and mount normally through USB 3.0 after i install ntfs-3g and reboot the laptop.

Writing and reading files is also work without problem.

1 Like

Installing ntfs-3g made your USB 3.0 ports work? That’s very strange.

Are the USB 2 ports on the same laptop?


So basically - you didn’t have the necessary driver to read NTFS - and as such it had nothing to do with USB3?


should be installed per default for all choices on EOS ISO…


I wonder whether there was a kernel update and so the laptop just needed rebooting (and so it had nothing to do with USB 3 or NTFS-3G).

1 Like

I wonder also as ntfs-3g is installed as part of the packages as @joekamprad said.

1 Like

Hello everyone

Well bad news, my hdd external is not detected again.

I have to reboot the laptop so it can be detected.

It happen so often, I think the problem is hardware related. But I’m not sure because it works just fine when I used linuxmint.

When you say it happens so often what do you mean? If you boot it and it’s detected as you say that means it can see the device. Then you can mount it or it is already mounted. There is a difference between the device being seen or recognized and being mounted so you can access it? So when you say it happens so often does the device disappear? Or you can’t mount it?

Edit: If the device is disappearing after a while i would suspect it is power management of the usb?