Upgraded my CPU and motherboard and now Endeavouros won't work with my front audio

Both the input and output are detected, but it still uses my speakers as output anyways even with the headphones selected, and input (mic) doesn’t work at all. does anyone have any ideas on what is causing this? (windows works perfectly with my front audio btw)
inxi -Fxxc0z --no-host | eos-sendlog hardware info: https://clbin.com/Z6MWC
journalctl -b -0 | eos-sendlog boot log: https://clbin.com/x1lup

Please post logs as per:

1 Like

sorry about that, I changed it now.

Front audio implies header connections.

If the rear ports work correctly then it implies the connections are wrong.

2 Likes

windows detects and uses front ports perfectly so I don’t think thats the issue.

@sheast21
Can you post the output

dmesg | grep snd_hda 

The output for dmesg | grep snd_hda is:


[    3.227522] snd_hda_intel 0000:00:1f.3: enabling device (0000 -> 0002)
[    3.227741] snd_hda_intel 0000:01:00.1: enabling device (0000 -> 0002)
[    3.227803] snd_hda_intel 0000:01:00.1: Disabling MSI
[    3.227805] snd_hda_intel 0000:01:00.1: Handle vga_switcheroo audio client
[    3.741102] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])

These intel audio problems are getting to be every time i see an Alder lake chip. :face_with_raised_eyebrow:

other alder lake users have had audio issues?

I’m not sure if it’s alder lake or tiger lake?? It just seems like intel audio issues…lately and they are hard to figure out and or fix. It’s difficult when you don’t have the hardware or the problem. There are so many different things with the audio. :tired_face:

yeah. it seems like it would be pretty simple, but apparantly it’s not. I used bluetooth audio, and even it worked perfectly fine, but front audio just isn’t.

also even on my old 8700k, I found that my headphones replaced my speekers and I didn’t have access to my speakers anymore as long as my headphones were connected, I just found that a bit odd since it wasn’t appearing as another device

There are so many things you can try or should i say you’re going to have to try in order to fix this problem. I think if it was me i would attack it by starting from the beginning. Have only speaker out from the rear and try to get that working properly first on the right default audio output. Then work on the headphones etc.

What type of headphones are they? You are plugging them in or bluetooth?

I have 2 headphones, 1 is a hyperx cloud (wired), and the other is sony wh1000xm4 (bluetooth). back audio jack with speakers and headphones and bluetooth works fine but wired from the front isn’t working.

I would say that’s a hardware issue then. Maybe it’s not connected properly on the board?

Screenshot_20220524_222129

2 Likes

oh lol I was just going to get my motherboard manual just to make sure I plugged things right. thanks

1 Like

I’m on the ball! :wink:

hold on, I have to turn off my computer to check.

Make sure it’s unplugged and your grounded. :wink:

yeah I just tried re seating the cable and same issue. I also tried switching from linux-zen to normal linux and that still didn’t solve it.