Updating unused system to current version

I have a lab PC in my garage that hasn’t been used in 5 months, so today I happened to have time to turn it on and update it. At the point it’s telling me about untrusted pgp keys on packages and I can’t seem to get by it. I hate to reinstall EOS, but I can. I have run into this just about every time I haven’t used a system for months. Is there a tried and true way to fix this?

I’ve tried pacman -Scc and then -Syyy and -Syu.

You could try refreshing the keys, search the forum.

try the update in terminal button on welcome app

Update keying first and all by itself, then proceed.

sudo bash -c "pacman -Sy archlinux-keyring endeavouros-keyring && pacman -Su"

doesn’t updateinterminal do this??

I first tried the update using the welcome screen. Then I tried a lot of stuff. I got the update installed using what @manuel suggested:
sudo bash -c "pacman -Sy archlinux-keyring endeavouros-keyring && pacman -Su"

It was successful in getting the updates install, but now grub seems to be missing. At this point, I can’t trust what is on the system, so I’ll reinstall EOS. I was wanting to move to Plasma on this PC since my others are already there.

Check out the big purple pinned banner at the top of any forum page…


1 Like

Been there done that on other systems. I can reinstall faster and get Plasma Desktop in the process

You can reinstall a whole system, back to how you have it setup, with programs, settings and everything faster than the 30 seconds it takes to chroot and 30 seconds to reinstall grub?!? Your internet connection must be unfathomable fast.

1 Like

Only if setting EOS_UPDATE_ARCH_KEYRING_FIRST in file /etc/eos-script-lib-yad.conf has value "yes".

1 Like

on a fresh install the value is “no”. I have never changed it so that explains why it didn’t fix it for me on the original update in terminal

1 Like

Yes, the default is "no" because that way it is closer to the default operation of pacman.
Whether that is a good default or not is debatable… :sweat_smile:

1 Like

I update frequently enough so I’ve never needed it :relaxed:

True, usually the keyring problem arises when update interval is long…
And Arch devs have a systemd service available for updating the Arch keyring,

1 Like