Updated today... Cannot connect to WiFi

I’m just curious if anyone else is having trouble connecting to wifi. I think I saw wifi applet update or something similar I cannot remember. But either way, I have managed to connect to WiFi only once. It’s weird. Does anyone have any ideas?

Hi Jeff,

could you give the result from :

rfkill list

lspci 
lsusb

or better boot log:


all together oneliner:
lspci > log.txt && lsusb >> log.txt && journalctl -b -0 >> log.txt && cat log.txt | curl -F 'f:1=<-' ix.io

At least your soft and hardware wifi are not blocked.
We need to know your material for help, follow @joekamprad ask

*If you can’t edit the network manager configuration, you can try a new network manager by the following command:

sudo pacman -S network-manager-applet

*then, edit NetworkManager.conf:

sudo nano /etc/NetworkManager/NetworkManager.conf

*add these lines, then save:

[device]
wifi.scan-rand-mac-address=no

restart Network Manager:

systemctl restart NetworkManager

source: https://youtu.be/P7bAp4vBxnA

If this is not a dual-boot setup please ignore this answer.

If this is a dual boot, try booting the other OS (presumably windows) and make sure that in other OS the wireless is not disabled. It happened to me. Simply booting the secondary OS and then booting back into Arch fixed it. The reason being some switches are more persistent than others and some OSes go lower-level than others in setting the power-states of some devices.

Same here …

All morning I was trying to get wifi (Broadcom 43142) working, I couldn’t get it to work until I got an RJ45 ethernet cable and was able to upgrade.

The packages I needed were just updated:

2020-01-25T14:22:46-0300] [ALPM] upgraded dhclient (4.4.1-5 -> 4.4.2-1)
2020-01-25T14:22:46-0300] [ALPM] upgraded wpa_supplicant (2:2.9-4 -> 2:2.9-5)

Everything is back to normal :slight_smile:

Thanks for all of the responses… I am without computer this weekend and I will get back to everyone Monday.

Hey all - I managed to get a thunderbolt to Ethernet adapter and ran another update and it works. I saw wpa_supplicant updated… maybe that was the problem? Who knows - but thanks again for all of your help.

2 Likes