Updated nVidia - something is not right

  Device-1: NVIDIA GA104M [GeForce RTX 3070 Mobile / Max-Q] driver: nvidia
    v: 515.43.04
  Device-2: Acer Integrated Camera type: USB driver: uvcvideo
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 21.1.99 driver: X:
    loaded: modesetting failed: nvidia gpu: nvidia,nvidia-nvswitch
    resolution: 1920x1080~144Hz
  OpenGL: renderer: llvmpipe (LLVM 13.0.1 256 bits) v: 4.5 Mesa 22.1.1

The OpenGL renderer is all wrong, downgraded:

  Device-1: NVIDIA GA104M [GeForce RTX 3070 Mobile / Max-Q] driver: nvidia
    v: 515.43.04
  Device-2: Acer Integrated Camera type: USB driver: uvcvideo
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 21.1.99 driver: X:
    loaded: nvidia unloaded: modesetting gpu: nvidia,nvidia-nvswitch
    resolution: 1920x1080~144Hz
  OpenGL: renderer: NVIDIA GeForce RTX 3070 Laptop GPU/PCIe/SSE2
    v: 4.6.0 NVIDIA 515.43.04

Steam doesn’t run on new driver. New to nVidia, what further info is needed?

1 extra/nvidia-dkms 515.48.07-2 (29.8 MiB 52.5 MiB) (Installed: 515.43.04-2)
    NVIDIA drivers - module sources

Just noticed - both inxi say 515.43.04…

Yup it is broken:

@jonathon heads-up :smiley:

1 Like

I’m fully up to date, but I don’t have this particular problem with my hardware, but in the meantime if you want to stay up to date with nvidia, the latest drivers are working just fine on the linux-lts kernel and some users are even reporting it’s working as well on the linux-zen kernel too, but your mileage may vary. Feel free to use either of those while using the latest nvidia driver, can’t go wrong with the LTS kernel :wink:

1 Like

What card? RTX3070 here

Nvidia MX150/intel hybrid optimus setup, though i only use the nvidia GPU, never the Intel

Older card, so may have saved you :smiley:


I am also full updated with GTX 1060. I don’t play games so i don’t know if there are any issues with steam.

Edit: I’m running on 515.48.07-2

I’m also having black screen issues with GTX 1660 super since after v495 drivers. Downgrading broke Steam so installed Pop_OS for now.

Downgrading should not have broken Steam (on v470 for now). I’ve had to do this a couple of times when newer drivers - v495 and v510 - led to major artifacting in a couple of games.

After upgrading to 515.48 I had a weird bug in Horizon Zero Dawn, which has otherwise been rock-solid on my 3070: opening the map and going back to the game resulted in the right third of the screen being black with some oily rainbow effects.

I downgraded with eos-shifttime and everything is fine for now.

edit: if I can’t wait until the next nvidia version to upgrade my system, I’ll try and see whether the LTS kernel makes any difference.

Is Horizon Zero Dawn a Linux or Windows game?

What does inxi -G return?

Windows, run via Proton Experimental.

The game, Proton, and the drivers could each be the culprit; all I know is that everything ran fine with .43 (and previous versions) and was borked with .48. I didn’t do any troubleshooting beyond reversing the update.

For all I know, if I upgraded again to .48, everything might now run fine because a Proton upgrade fixed it…

It can be a bear to find the right combination of game/Proton/Nvidia. I’ve been pretty happy with Proton 7, but I only have (2) Windows-native games: D2R and Worms: Armageddon.

Hopefully, once a few revisions of v515 are released, the performance will be more consistent.

D2R = Diablo II Resurrected ? If so, that’s not a Steam game, so I haven’t tried it under Linux yet.

I have tried a lot more than 2 games under Proton, and found that most run pretty fine, if you can afford a 15~20% performance tax in some (like HZD).

That said I have only been seriously gaming on linux for a few months (since I switched from Kubuntu to Endeavour for my new main machine, which can afford the tax), and the only games I’ve played with some real intensity on linux (as opposed to a few minutes of testing) are Elden Ring, HZD, and AoE II DE, which all ran flawlessly (until the .48 incident mentioned above).

Interestingly, HZD is only Gold on protondb, with many people reporting problems, so maybe I just got lucky…

For D2R, every aspect of the game runs better under Linux: video performance/usage, framerate, memory/CPU usage. I actually installed the Battle.net client under Steam, then installed D2R and D3 from there. Works like a charm!


Thanks for that; the previous advice I’d seen mentioned Lutris, which pulls too many dependencies to my taste, but merely adding the Battle.net installer as a non-steam game worked just fine!

In the meantime, I’ve upgraded and narrowed down the problem with HZD under .48 nvidia drivers: the problem only happens when using DLSS in Fullscreen or Borderless modes [edit: ah, no, I also reproduced it in Windowed mode], so it’s bizarrely specific… and, I’m realising, certainly completely unrelated to the thread’s original problem. Sorry for the tangent.

To verify if you are affected

I need this to check your CPU model/gen. Intel gen 11+ is affected.

inxi -C

Ryzen 5800

We’ve got the exact same laptop model, and mine is working fine with 515.48.07 (running with discrete graphics), so I don’t know what you’ve done to yours. :stuck_out_tongue_winking_eye:

Do you still have a module version mismatch? If so, what does dkms status report?

1 Like