Updated kernel to 5.19.1, the WiFi driver broke

I got the Realtek RTL88X2BU WiFi adapter and after updating to kernel 5.19.1 the driver (AUR package rtl88x2bu-cilynx-dkms-git) is not working anymore. I tried swapping r8169 in favor of r8168 from the welcome app, but this did nothing. Possibly related to:

What is your hardware?
Edit: Sorry i see you posted above.

Have you rebuilt the package recently?

In what way?

What does the DKMS build log report?

That’s for completely different Ethernet hardware so it won’t affect your wifi card.

Have you tried the other AUR package?


That one lists kernel 5.19 support, so it’s a good shout.

1 Like

I’ll try it, it used to break like the one I use now though

I installed EndeavourOS (and that means the driver too) 3 days ago

No networks are shown

Where is the log located?

It did work, but will it be stable in the long run?

I can’t answer that. You’ll just have to see.

Let’s hope it won’t :crossed_fingers:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.