Update Problem - DB can't be syn (solved)


I have some problems to update my system.
How can I remove the repro “sublime-text” from the DB? Or is there a possibility to repair the system?

sudo nano /etc/pacman.conf

Find the lines and add a # to the front (or delete).

OK. Thanks, that worked. But know i have another problem:

Signature from unknown trust.
Can I update this?

Please stop pasting pictures of text output. Instead paste the test into a code block.

For this issue, try this:

sudo pacman -Sy archlinux-keyring endeavouros-keyring
sudo pacman -Syu

This error is common if you don’t update often enough.


I tried this, but with no success:

:: Paketdatenbanken werden synchronisiert …
 endeavouros ist aktuell
 core ist aktuell
 extra ist aktuell
 community ist aktuell
 multilib ist aktuell
Warnung: archlinux-keyring-20230504-1 ist aktuell -- Reinstalliere
Abhängigkeiten werden aufgelöst …
Nach in Konflikt stehenden Paketen wird gesucht …

Paket (2)                        Alte Version  Neue Version  Netto-Veränderung  Größe des Downloads

core/archlinux-keyring           20230504-1    20230504-1             0,00 MiB             1,14 MiB
endeavouros/endeavouros-keyring  20220614-1    20230523-1             0,00 MiB             0,02 MiB

Gesamtgröße des Downloads:             1,16 MiB
Gesamtgröße der installierten Pakete:  1,62 MiB
Größendifferenz der Aktualisierung:    0,00 MiB

:: Installation fortsetzen? [J/n] 
:: Pakete werden empfangen …
 endeavouros-keyring-20230523-1-any                                                                                 20,2 KiB   289 KiB/s 00:00 [----------------------------------------------------------------------------------------] 100%
 archlinux-keyring-20230504-1-any                                                                                 1164,5 KiB  5,42 MiB/s 00:00 [----------------------------------------------------------------------------------------] 100%
 Gesamt (2/2)                                                                                                     1184,8 KiB  5,03 MiB/s 00:00 [----------------------------------------------------------------------------------------] 100%
(2/2) Schlüssel im Schlüsselbund werden geprüft                                                                                                [----------------------------------------------------------------------------------------] 100%
(2/2) Paket-Integrität wird überprüft                                                                                                          [----------------------------------------------------------------------------------------] 100%
Fehler: archlinux-keyring: signature from "Christian Hesse <eworm@archlinux.org>" is unknown trust
:: Datei /var/cache/pacman/pkg/archlinux-keyring-20230504-1-any.pkg.tar.zst ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] ^C
Interrupt signal received

I didn’t update for a week.

That isn’t long enough to cause this issue. Something is probably wrong with your keyring.

Try following the steps in this post:


Many Thanks!
I used the step by step explanation of your link and got the system “back to work”.

Kind regards,


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.