Update Error Help

Hello all, I have been getting an error when tying to update my system. I use yay or -Syu and I get the same problem as follows:

(82/82) checking package integrity [--------------------------------------------------------------------] 100%
error: libinih: signature from “Maxime Gauduin alucryd@gmail.com” is marginal trust
:: File /var/cache/pacman/pkg/libinih-55-2-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.
→ error installing repo packages
[zut@EOS ~]$ cd /var/cache/pacman/pkg
[zut@EOS pkg]$ rm libinih-55-2-x86_64.pkg.tar.zst
rm: cannot remove ‘libinih-55-2-x86_64.pkg.tar.zst’: No such file or directory

I can’t remove the file that is giving me trouble. So I am not able to update. Any ideas would be appreciated


Please disregard, I found an older thread and fixed it myself.



In order to educate the community, you could describe what the solution was.

1 Like

Edit. Maybe?

More details are here https://bbs.archlinux.org/viewtopic.php?id=275924
worked for me.

This was the thread that solved my issue. Thanks to all that sent me advice, that is what is nice about EOS. The great support!


Yes, more than two years after the existence of the EOS, a fairly good amount of archives have been gathered from the questions asked and answered.

the issue was this:

Signing keys was changed but the keyring package was not updated before tried to update packages with the new keys…

So in such cases updating the archlinux-keyring package will solve the issue…
sudo pacman -Sy archlinux-keyring
and run update again…