Unusual problem with the wifi

Hi everyone, i am not a linux systems expert and i have been using linux for a year. I have installed EndeavourOS on SurfacePro 4 for a month now, no problem so far but the latest update has disabled the wifi of the device. I was using a modified kernel for the surface. I tried looking for a guide to fix my problem, but I couldn’t find anything. I tried to reinstall the system, the unusual thing is that during the installation the wifi works and detects the networks. After installation, the wifi does not work and does not detect anything, it is as if the surface has no network card detected. I tried to install Manjaro and the wifi works normally. Can anyone help me fix this problem?

Thank you!

You need this package:




Thanks for giving EndeavourOS a try, and Welcome to the forum. I hope you enjoy your time here.

Hopefully, @TheRaOct has solved your problem. If not I’m sure someone here can help.


Thank @TheRaOct, problem solved. Will bluetooth also work with this package? Obviously after configuring it with blueman.

On my Surface, bluetooth still works (after installing said package), so I would assume that it should work. But depending on your model, you might run into different problems. If you have problems that can’t be addressed here, it is probably a good idea to get in touch with the linux-surface-kernel guys.

Also if you could mark the answer as solution for other people to find :wink:

Go to @TheRaOct 's post and then Click on the three horizontal dots … next to Reply.
Then click on “Solution” to mark that post as the solution to your problem.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.