[UNSOLVED] I Need Help with Installation to Computer with Two Hard Drives

Here are photographs of the various tabs in the UEFI/BIOS of this Alienware computer.

I’m sorry for all of these photos but I do not know of any other way to show the UEFI/BIOS here.

I hope that this may give someone a clue as to what I can do. If there are any other photos you may want, pleas let me know.

Thanks for trying to help me and thanks for your patience.

Lawrence

The only thing I see there that I would change is the ‘Legacy Option ROM’ - which I have to assume is the CSM (Compatability Support Module) and unneeded and possibly detrimental on an UEFI system. I very much doubt it is the source of your troubles though…sorry.

2 Likes

@lhb1142
I don’t see anything out of the ordinary on your settings. It shows both Integrated Graphics (Intel) and Discrete Graphics. (Nvidia)

Anyway I suggested you try installing and select the Nvidia drivers during the online install with the current kernel. Lets see where that goes first.

1 Like

if you dont have windows on your disk

  • set disks to AHCI not Raid
  • set if possible Legacy Option Rom on disable
  • add this option on boot kernel “nvme_core.default_ps_max_latency_us=0”
2 Likes

Fwiw, Linux 5.4 kernel series will be supported until December 2025.

1 Like

@jonathon has built some LTS kernels too: Unofficial repo for older LTS kernels

2 Likes

Dear pebcak,

Thank you very much for this information. I am going to reinstall the system and, after updating it, installing the lts kernel (as well as grub-customizer), and rebooting into the lts kernel, I am going to remove the Linux 5.10.x kernel and use only the lts kernel.

This computer worked more-or-less fine with the UEFI/BIOS set to its defaults (using it in Legacy mode) until Linux 5.10.x came along - and that was the end of it. Obviously it doesn’t work in UEFI-enabled (and Secure Boot disabled) mode either. Evidently 5.10.x is completely incompatible with this computer.

But the lts kernel works well and, if it will be supported for almost five more years, that will work out just fine for me. By that time I’ll want a new computer anyway for what I do with this one (assuming I’m still around).

And manuel - thanks for the tip about jonathan’s “unofficial” lts kernels. I may add one of them as well if I feel that I need a backup kernel.

A BIG THANK YOU to everyone here who has responded to me with suggestions.

If everything works with just the lts kernel installed, I’ll report that here and will mark the question as solved.

Thanks again!

Lawrence

1 Like

Here you can find more information about the LTS (and other) kernels: https://www.kernel.org/category/releases.html

Their Projected EOL tells how long they are supported by the upstream kernel devs.
Note that kernel 5.10 is marked for year 2022, but I’m sure they will change it later to be more in line with the older LTS kernels, probably to the end of 2026.

But I still do no get why you insist on this. The last release is two years old. Even if you are not able to boot with the default kernel, you should boot a live system, arch-chroot and create a working grub configuration with the LTS kernel from there.

Just my 2 cents…

3 Likes

I can see setting the disk controllers to AHCI mode as opposed to RAID and Legacy Option Disable and run only UEFI. But, the only reason to use this parameter would be if your system is working and has a sudden outage on the drive as if someone unplugged it from my understanding? I know sometimes nvme disks are not recognized properly and or are named differently. :thinking:

Dear csteinforth,

The only reason I used grub-customizer was to allow me to set the order of the kernels at boot.

I have reinstalled the system and, after the initial update and before rebooting, I installed the linux-lts kernel.

When I rebooted the system, the lts kernel showed up first (it is the default) and the computer booted just fine.

The 5.10.x kernel is now an option and of course I will not use it because this computer just won’t boot using that kernel.

I am going to try something: I’m going to remove that 5.10.x kernel, leaving only the lts kernel.

Then, when I get around to it, I’ll add jonathan’s repository and add an older lts kernel as a backup.

I think that will work. I’ll find out sometime later this week (and I’ll post the results here).

After all I have read about grub-customizer, I’d prefer to avoid it at this time, even though I myself have never had a problem with it

Of course, without grub-customizer, I have no means of rearranging the order of the kernels on the boot screen. Is there another way to do this?

Thanks again to everyone who has participated in this discussion and who have helped me. I have to say that all of you have been a great help to me and I truly appreciate it.

Lawrence

Dear Stephane,

I did not add the line that you recommended because, yesterday, it did not do anything regarding booting into 5.10.x.

And until that latest kernel was introduced, this computer worked well without my modifying the grub at all.

I guess that, at least with this computer, that line is not necessary.

Thanks for your help and suggestions.

I’ll continue to report on what is happening with this Alienware computer as I go along. I do hope that I can get it fully functional later this week.

Thanks again.

Lawrence

Next time just (sudo-)edit /etc/default/grub and run sudo grub-mkconfig -o /boot/grub/grub.cfg afterwards.

You can change the default boot entry by changing
GRUB_DEFAULT=0
to the second entry by using =1, the third entry corresponds to =2, etc.

You can instead make GRUB remember the last selection. This requires setting GRUB_DEFAULT=saved
GRUB_SAVEDEFAULT=true

You see, there’s no need for grub-customizer!
Note: The above won’t rearrange the boot order visually, only the actual chosen entry.

5 Likes

Usually there is no need to sort the entries since grub can be configured to select the entry you chose in the last boot as default selection which could the lts kernel. AFAIK grub sorts the kernels in that respect that the latest kernel becomes the default.

Grub sorts kernels by version in reverse order so that the latest kernel with the highest version number becomes default. I recently installed the lts kernel, too, and although I do not use grub I checked the grub menu where the lts kernel was at the first position.

Edit: While I was typing @2000 wrote already a thorough explanation.

2 Likes

[quote=“2000, post:53, topic:11104”]
Next time just (sudo-)edit /etc/default/grub and run sudo grub-mkconfig -o /boot/grub/grub.cfg afterwards.

You can change the default boot entry by changing
GRUB_DEFAULT=0
to the second entry by using =1, the third entry corresponds to =2, etc.

You can instead make GRUB remember the last selection. This requires setting GRUB_DEFAULT=saved
GRUB_SAVEDEFAULT=true

You see, there’s no need for grub-customizer!
Note: The above won’t rearrange the boot order visually, only the actual chosen entry.
[/quote]strong text

Wow! I suppose that will work - but what a mess! The grub-customizer does the same thing far more easily and it does arrange the boot order visually.

Not that I want to get into a discussion about grub-customizer but, even if it has not been updated in a couple of years, it seems to work fine and I personally have never had even the most remote problem with it. I use it strictly to rearrange the order of booting if, and when, it’s necessary to do so.

Fortunately on this Alienware computer I have not needed to install it as the Linux-lts kernel is the default since I installed it.

Lawrence

Did you not install the nvidia drivers?

1 Like

Dear ricklinux,

No I have not installed Nvidia drivers as I do not want to use Nvidia on this (or any!) computer.

So far, using the lts kernel, this Alienware computer seems to be working normally. The 5.10.6 kernel was introduced this morning - and the Alienware still won’t boot into that!

But just as long as I can use the 5.4.x lts kernel, I’ll be “happy.”

Lawrence

:thinking:

1 Like

Well it’s your choice if you are happy with that. I was just wishing you would have tried installing it with the nvidia drivers and the current kernel during the online install.

1 Like

Dear ricklinux,

What I do not understand is why this computer will not boot up when using the 5.10.x kernel. I had formerly used several different distros on this machine since I got it in 2016 (it was originally a Windows gaming computer but I immediately converted it to Linux alone).

After I had some problems with Debian-based distros (not with the computer but with certain programs I use), I switched over to Antergos and, when that went away, over to EndeavourOS.

I set the UEFI/BIOS to Legacy mode and, since August 2019, the computer and all of my programs worked okay (something I could not say with Debian-based systems).

As soon as kernel 5.10.x was introduced, that was the end of it. There is something about this kernel that this computer doesn’t like and, for the life of me, I can’t figure out what the problem is.

I tried reinstalling and then updating - and since, when reinstalling only one kernel (the latest) is available and when updating still only one kernel (again the latest) is available, that being 5.10.x, the computer would not boot at all.

As this time I had set the UEFI/BIOS to UEFI enabled and Secure Boot disabled, the boot process would stall just before LightDM was to come up.

Fortunately I used my head and, after reinstalling again with the latest ISO (which still used kernel 5.8.x) and updating (which installed 5.10.x) and BEFORE rebooting, I installed the Linux-lts kernel so I could boot into that.

So that is what I am doing currently with this computer (using the lts kernel). You can read the “sad history” of my attempts at reinstalling by reading earlier posts in this thread. And, so far, it is working.

But what I cannot figure out is what about 5.10.x does this computer not like? The computer always worked okay up until this new kernel was introduced and then “boom.”

I got quite a few suggestions here but none of them helped (as far as booting into 5.10.x).

I never had to use Nvidia graphics drivers before and, as I am not a gamer, I do not want to use them now.

And why should I have to? The computer had always worked properly with all kernels up until 5.10.x.

I wish someone could figure out just WHY this computer doesn’t “like” that kernel.

What I am also afraid of is that eventually the lts kernel will be upgraded to 5.10.x-lts and, unless there is some solution to my problem, I’ll have to make certain that I do not upgrade to that.

I do thank you and everyone else for their attempts to solve the problem. I also continue to hope that someone can determine just what the problem actually is though that may not be too important at this time as the computer seems to working okay with the lts kernel.

Thanks again.

Lawrence