Unreal tournament can't go online

Hi! A newbie here.

After finally figuring out how to set up my graphics drivers, I managed to install UT99 from AUR, specifically the gog-unreal-tournament-goty package.

Now, I ran into an issue, and no matter how much I search online I can’t figure it out. Going to “online” menu, it will not connect. No news show up, nor does the server list get populated. I tried opening up all the ports I used to open on Windows with firewalld, but no luck.

Thanks in advance if anyone can help out.

I managed to fix it. During the install from AUR using yay it claims to apply the 469 patch (unsure if it was 469c or 469d-rc1/2), but I went on to ut99.org, found the 469d-rc2 patch, download, apply and it now works. Sometimes it takes a while to actually start pinging servers and populating the list, but it’s better than connecting to servers with their IP addresses which worked.

Even better, the performance is a lot better than I had on Windows, or Linux mint where I unpacked the .exe and ran the unpacked exe files as a “native” linux install! For the first time it actually downloads all the assets, on both previous OS it skipped some files and worked weird.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.