Unreadable icons which do not respect zoom setting

Look at this sadly completely unreadable mess:

These must be custom EndeavourOS icons as vanilla Gnome does not look this ugly.

How can I revert it to something which respects the zoom setting of the desktop (which in my case is 300% on a 4K screen)?

Also, this won’t matter since I can’t see it unless I put my nose to the screen, but that non-standard mouse cursor is also quite pixellated up close.

EDIT: No wait, the cursor matters! It should also be 300% larger and I’m fairly sure it’s not!

Two posts in the space of two minutes with complaints and ridicule, rather than humbly asking for assistance.

This is not how you get help. We aren’t your paid customer service.

Which distro or OS were you using before?

2 Likes

I’ve tried OpenSuse Aeon and Fedora Silverblue, both had Vanilla Gnome which respected desktop zooms in both icons and mouse cursor as far as Gnome currently supports it (there’s still a login screen issue which seems repeatable throughout any distro).

Sorry, I’m just… very, very, very close to going back to Windows. Linux has so far been extremely frustrating, even though for every distro there are super knowledgeable people who try to help, but unless you have years of Linux experience, it still feels as if the OS fights you every step of the way. It’s the piracy analogy, right? It’s not a cost issue, it’s a service issue.

:sweat:

This seems to be an issue with your expectations of Linux vs your level of understanding and “tech-savvyness”.

That being said, you don’t need to be tech-savvy to get things exactly how you want them, but you do need to be patient.

So patient that you’ll have to wait for someone to pass through and help. I don’t use Gnome and haven’t used it for years, so I can’t help with either of your threads.

Unless you’re will to try another DE? Like Cinnamon, for instance or KDE under an x11 session.

Speaking of which… Wayland. What is the output of the command below:

inxi -FGA

I asked because you may just need to use Gnome under an x11 session instead of Wayland.

Oh, you’re not going to like me at all… :sweat_smile:

Basically, the only reason I’m taking Linux on the desktop seriously these days is because they finally dumped that ancient, old fossil that is X11. :face_with_peeking_eye:

  Host: leplup Kernel: 6.9.3-arch1-1 arch: x86_64 bits: 64
  Desktop: GNOME v: 46.2 Distro: EndeavourOS
Machine:
  Type: Desktop Mobo: SAPPHIRE model: BP-FP6 v: I917H020
    serial: <superuser required> BIOS: American Megatrends v: 5.16
    date: 10/22/2021
CPU:
  Info: 6-core model: AMD Ryzen Embedded V2516 with Radeon Graphics bits: 64
    type: MT MCP cache: L2: 3 MiB
  Speed (MHz): avg: 1574 min/max: 1400/2100 cores: 1: 1397 2: 1400 3: 1398
    4: 1400 5: 1400 6: 2100 7: 2100 8: 1400 9: 1400 10: 1400 11: 2100 12: 1400
Graphics:
  Device-1: AMD Renoir [Radeon Vega Series / Radeon Mobile Series]
    driver: amdgpu v: kernel
  Display: wayland server: X.Org v: 24.1 with: Xwayland v: 24.1.0
    compositor: gnome-shell driver: gpu: amdgpu resolution: 3840x2160~60Hz
  API: EGL v: 1.5 drivers: radeonsi,swrast
    platforms: wayland,x11,surfaceless,device
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.1.1-arch1.1
    renderer: AMD Radeon Graphics (radeonsi renoir LLVM 17.0.6 DRM 3.57
    6.9.3-arch1-1)
Audio:
  Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: N/A
  Device-3: AMD Family 17h/19h HD Audio driver: snd_hda_intel
  API: ALSA v: k6.9.3-arch1-1 status: kernel-api
  Server-1: PipeWire v: 1.0.7 status: active
Network:
  Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: enp1s0 state: down mac: dc:9c:52:08:a4:c6
  Device-2: Realtek RTL8192EE PCIe Wireless Network Adapter
    driver: rtl8192ee
  IF: wlan0 state: up mac: 30:10:b3:98:7a:e3
Bluetooth:
  Device-1: Realtek Bluetooth Radio driver: btusb type: USB
  Report: btmgmt ID: hci0 rfk-id: 2 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: N/A
Drives:
  Local Storage: total: 2.27 TiB used: 1.79 TiB (78.7%)
  ID-1: /dev/nvme0n1 vendor: Kingston model: SNV2S500G size: 465.76 GiB
  ID-2: /dev/sda vendor: Samsung model: PSSD T7 Shield size: 1.82 TiB
    type: USB
Partition:
  ID-1: / size: 465.76 GiB used: 4.5 GiB (1.0%) fs: btrfs dev: /dev/nvme0n1p1
  ID-2: /home size: 465.76 GiB used: 4.5 GiB (1.0%) fs: btrfs
    dev: /dev/nvme0n1p1
  ID-3: /var/log size: 465.76 GiB used: 4.5 GiB (1.0%) fs: btrfs
    dev: /dev/nvme0n1p1
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 45.6 C mobo: N/A gpu: amdgpu temp: 28.0 C
  Fan Speeds (rpm): N/A
Info:
  Memory: total: 32 GiB note: est. available: 30.77 GiB used: 1.92 GiB (6.2%)
  Processes: 338 Uptime: 52m Shell: Bash inxi: 3.3.34

x11 hasn’t been dumped, but okay. :+1:

Anyway, try switching to x11 to see if the issues remain. If they don’t, then you know what the actual issue is. If they are still present, then more troubleshooting is needed.

PS: I wouldn’t be surprised if based on your aversion to x11, you don’t actually try, but either way, a possible solution has been suggested. :wink:

4 Likes

Linux isn’t there as a service to you, it’s an operating system. There’s a way to do just about anything. If icon scaling and look & feel are frustrating, wait until you hear about windows :smiley: It’s also clearly not a general Linux issue, as you said yourself it didn’t occur on Silverblue/Aeon.

But, without getting into hardware diagnostics, have you tried switching to the standard gnome/adwaita icon set? That can be done through the user themes extension, GNOME tweaks, or gsettings. < you should be able to choose the default cursor through these as well.

2 Likes

I’m actually looking into it and having a surprisingly difficult time figuring even that out! :sweat_smile:

I see there’s a site for icon downloads, but it’s not clear if this is also includes “system tray” icons (sorry, I have to use the terms I know… the icons in my first image) or not and the user themes extension offers no clue on how to install themes. That site says you should get a .theme file but when I double click that it just opens a text file, and the install button on the website itself doesn’t work, while the ~/.icons folder some other sites mention doesn’t exist for me… I hope I’m missing something obvious.


(Screenshot from my other Linux machine, not EndeavourOS but still Gnome.)

You’ll have to manually create .theme and .icon folders within your home directory for custom themes. Gnome 40+ has made theming awkward, and there are some extra steps including a symlink to custom CSS (if you’re wanting to change the LibAdwaita theme)

I’d recommend using this to graphically select icons/cursors. https://archlinux.org/packages/extra/any/gnome-tweaks/

Based on your suggestion before this, they should actually try the default icons first, not download something. You should probably focus on that, then if it doesn’t work, guide them through adding extra icon packs and themes.

You were on the right track as far as troubleshooting is concerned. Don’t let them steer you away from it.

1 Like

sorry, to clarify: that’s what I was recommending gsettings or gnome-tweaks for. (assuming the issue is coming from a custom icon set). Forgot to mention setting them to Adwaita specifically

1 Like

Since you’ve been using Windows for years, it will take time to learn a new os because Linux is not Windows and you didn’t come into this world knowing how Windows worked you learned that as well over time. The comment about the os fighting you, just means that you are still in your learning phase of getting to know Linux, once you understand the basics things will fall into place and you won’t feel then need to fight it as much anymore.

1 Like

I know. I was saying that your second response:

should not be explored yet until the very basic changes in your first response are attempted.

1 Like

Thank you, gnome-tweaks and reverting to the default icon set worked!

But setting aside all helpful workarounds now, one big question still remains:

Why doesn’t the icon set EndeavourOS ships with respect the display scaling?

Right now, this seems like a bug that was specific to your system. Never seen anyone else with the same issue. Also, as much as you prefer Wayland, please know that it is not complete, and as such, it is prone to random issues on random systems.

Please mark @rinwolf1312 first reply to your thread as the solution for now.

1 Like

@eobet Before this thread closes, I’d like to take a moment to note that this exchange was a perfect example of how amazing the EOS community is.

The patience and perspective received in response to what sounded like initial criticism and flailing is hard to find elsewhere on the interwebs. :vulcan_salute:

5 Likes

Oh, yes. I must admit that after four weeks of distro hopping and encountering pretty much the same issues each time, I was quite cranky. :hot_face:

Now, if I can take another step back and reflect on the general Linux community… Linux is now at 4% market share… Microsoft is having “an episode”… what happens when the market share jumps to 8%? or 16%? I’m going to wager a guess that without many more UX improvements of distros out of the box, forums like these are probably going to get absolutely swamped. And the distributed nature of Linux makes it even more difficult to fix things. I mean, for this thread, was the issue my hardware (which is nothing special), the icon set itself, the distro, or even something within Gnome?

I just hope that UX is going to be something that Linux takes even more seriously in the future! :+1:

GNOME is a finicky environment. Custom themes and extensions can mess with icon sizes IME. Nearly every version bump breaks compatibility with previous versions of addons.

This in itself isn’t a great user experience, but it’s not representative of desktop Linux as a whole.

Right? We made it this far without dunking on GNOME :smiley:

2 Likes

Not quite sure where to go with this. Having such a long parade of choices when it comes to user interface is one of the hallmarks of the Linux distro universe. Pick your UX and off you go!

As for Microsoft, they use Linux/Unix to run their cloud services. That’s worth a moment of reflection. :wink: