Unreadable console on boot

Just installed EOS on my Lenovo Ideapad Duet 3i, mostly everything works (aside from the Fibocom L850-GL modem but who cares)

The one other issue is that after the loader menu timeout, the text on the console is unreadable as shown in the pic. One I authenticate Luks it clears up though, how can I fix this?

I already tried changing the console-mode both 0, then keep with no change.

See image

whats the output for lspci -k | grep -EA3 'VGA|3D|Display'?

1 Like
$ sudo lspci -k | grep -EA3 'VGA|3D|Display'                                                                         [0:50:37]
00:02.0 VGA compatible controller: Intel Corporation GeminiLake [UHD Graphics 605] (rev 06)
	Subsystem: Lenovo GeminiLake [UHD Graphics 605]
	Kernel driver in use: i915
	Kernel modules: i915
01:00.0 Non-VGA unclassified device: Intel Corporation XMM7360 LTE Advanced Modem (rev 01)
	Kernel modules: iosm
02:00.0 SD Host controller: O2 Micro, Inc. SD/MMC Card Reader Controller (rev 01)
	Subsystem: Lenovo SD/MMC Card Reader Controller

Do you have modesetting enabled?

inxi -Ga

Have a look at: https://wiki.archlinux.org/title/Intel_graphics
section 6 (Troubleshooting)

$ sudo inxi -Ga --display                                                                                                                           
  Device-1: Intel GeminiLake [UHD Graphics 605] vendor: Lenovo driver: i915 v: kernel
    arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports: active: none off: DSI-1 empty: DP-1,
    DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:3184 class-ID: 0300
  Device-2: Realtek Intergrated Camera 2M driver: uvcvideo type: USB rev: 2.0 speed: 480 Mb/s
    lanes: 1 mode: 2.0 bus-ID: 1-4:2 chip-ID: 0bda:5609 class-ID: 0e02 serial: 200901010001
  Device-3: Realtek Intergrated Camera 5M driver: uvcvideo type: USB rev: 2.0 speed: 480 Mb/s
    lanes: 1 mode: 2.0 bus-ID: 1-7:5 chip-ID: 0bda:5612 class-ID: 0e02 serial: 200901010001
  Display: server: X.org v: with: Xwayland v: 23.1.1 compositor: gnome-shell v: 44.1
    driver: gpu: i915 tty: 165x37
  Monitor-1: DSI-1 size-res: N/A in console modes: 1200x1920
  API: OpenGL Message: GL data unavailable in console for root.

did you try adding the tearfree option in /etc/X11/xorg.conf.d/20-intel.conf
as per the troubleshooting section of the wiki?

1 Like

Yes I tried this and it didn’t change anything.

So it’s been about 3 weeks, I never found a fix for this. I did however do a reinstall using GRUB instead of systemd boot. Now I can actually see the password prompt for on boot encryption, it’s even the correctly rotated.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.