Unable to update EndeavourOS due to error: could not find all required packages: nodejs-lts-gallium

Hi there,

I apologize for this silly question, but I’ve been unable to update my EndeavourOS computer since a month or so due to the following error.

When I attempt to update the system using sudo yay or sudo pacman -Syu, I encounter the following error message:

-> could not find all required packages: nodejs-lts-gallium

Here’s what I have tried to resolve the issue:

  1. looked for help online (forums / docs) → haven’t found any working solution
  2. tried to manually install nodejs (success but the error is still there)
  3. tried to manually install nodejs-lts-hydrogen (error: missing package nodejs-lts-gallium)
  4. look for dependencies of nodejs-lts-gallium with pamac -Si and pacman -Sii but there was no dependecy corresponding to gallium
  5. use pacman -Syu --assume-installed nodejs-lts-gallium; It updated the system (apart from 15 packages) but I almost destroyed the whole system, now I have switched back to a fully functional backup.

Obviously mirrors are updated.

Lastly, here are the details of my system from neofetch :
OS: EndeavourOS Linux x86_64
Kernel: 6.4.12-arch1-1
Shell: zsh 5.9
DE: Plasma 5.27.7

Has anyone experienced this problem before? Do you have any advice on how to solve it?

Thank you in advance,

P.S.: Sorry for any English errors!

Can you post the output of pacman -Qi nodejs-lts-gallium?

1 Like

Hi! Thank you for your help!
That’s the output:

error: impossible to find the package 'nodejs-lts-gallium'

I don’t know whether this can help, but just for reference, that’s the archlinux wiki page about nodejs: https://wiki.archlinux.org/title/node.js_ .
In the Installation section nodejs-lts-gallium is marked as “package not found”.

Could you show the full output of command

LANG=C sudo pacman -Syu

Tip: do not use sudo with yay.


Hi manuel! Thank you for your help!!

That’s the full output of LANG=C sudo pacman -Syu :

╰─ LANG=C sudo pacman -Syu
:: Synchronizing package databases...
 endeavouros is up to date
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
:: Replace attica with extra/attica5? [Y/n] y
:: Replace baloo with extra/baloo5? [Y/n] y
:: Replace bluez-qt with extra/bluez-qt5? [Y/n] y
:: Replace frameworkintegration with extra/frameworkintegration5? [Y/n] y
:: Replace kactivities with extra/kactivities5? [Y/n] y
:: Replace kactivities-stats with extra/kactivities-stats5? [Y/n] y
:: Replace karchive with extra/karchive5? [Y/n] y
:: Replace kauth with extra/kauth5? [Y/n] y
:: Replace kbookmarks with extra/kbookmarks5? [Y/n] y
:: Replace kcalendarcore with extra/kcalendarcore5? [Y/n] y
:: Replace kcmutils with extra/kcmutils5? [Y/n] y
:: Replace kcodecs with extra/kcodecs5? [Y/n] y
:: Replace kcompletion with extra/kcompletion5? [Y/n] y
:: Replace kconfig with extra/kconfig5? [Y/n] y
:: Replace kconfigwidgets with extra/kconfigwidgets5? [Y/n] y
:: Replace kcontacts with extra/kcontacts5? [Y/n] y
:: Replace kcoreaddons with extra/kcoreaddons5? [Y/n] y
:: Replace kcrash with extra/kcrash5? [Y/n] y
:: Replace kdbusaddons with extra/kdbusaddons5? [Y/n] y
:: Replace kdeclarative with extra/kdeclarative5? [Y/n] y
:: Replace kded with extra/kded5? [Y/n] y
:: Replace kdesu with extra/kdesu5? [Y/n] y
:: Replace kdnssd with extra/kdnssd5? [Y/n] y
:: Replace kdsoap with extra/kdsoap-qt5? [Y/n] y
:: Replace kfilemetadata with extra/kfilemetadata5? [Y/n] y
:: Replace kglobalaccel with extra/kglobalaccel5? [Y/n] y
:: Replace kguiaddons with extra/kguiaddons5? [Y/n] y
:: Replace kholidays with extra/kholidays5? [Y/n] y
:: Replace ki18n with extra/ki18n5? [Y/n] y
:: Replace kiconthemes with extra/kiconthemes5? [Y/n] y
:: Replace kidletime with extra/kidletime5? [Y/n] y
:: Replace kio with extra/kio5? [Y/n] y
:: Replace kirigami-addons with extra/kirigami-addons5? [Y/n] y
:: Replace kitemmodels with extra/kitemmodels5? [Y/n] y
:: Replace kitemviews with extra/kitemviews5? [Y/n] y
:: Replace kjobwidgets with extra/kjobwidgets5? [Y/n] y
:: Replace knewstuff with extra/knewstuff5? [Y/n] y
:: Replace knotifications with extra/knotifications5? [Y/n] y
:: Replace knotifyconfig with extra/knotifyconfig5? [Y/n] y
:: Replace kpackage with extra/kpackage5? [Y/n] y
:: Replace kparts with extra/kparts5? [Y/n] y
:: Replace kpeople with extra/kpeople5? [Y/n] y
:: Replace kpty with extra/kpty5? [Y/n] y
:: Replace kquickcharts with extra/kquickcharts5? [Y/n] y
:: Replace krunner with extra/krunner5? [Y/n] y
:: Replace kservice with extra/kservice5? [Y/n] y
:: Replace ktexteditor with extra/ktexteditor5? [Y/n] y
:: Replace ktextwidgets with extra/ktextwidgets5? [Y/n] y
:: Replace kunitconversion with extra/kunitconversion5? [Y/n] y
:: Replace kuserfeedback with extra/kuserfeedback5? [Y/n] y
:: Replace kwallet with extra/kwallet5? [Y/n] y
:: Replace kwayland with extra/kwayland5? [Y/n] y
:: Replace kwidgetsaddons with extra/kwidgetsaddons5? [Y/n] y
:: Replace kwindowsystem with extra/kwindowsystem5? [Y/n] y
:: Replace kxmlgui with extra/kxmlgui5? [Y/n] y
:: Replace libqaccessibilityclient with extra/libqaccessibilityclient-qt5? [Y/n] y
:: Replace modemmanager-qt with extra/modemmanager-qt5? [Y/n] y
:: Replace networkmanager-qt with extra/networkmanager-qt5? [Y/n] y
:: Replace plasma-framework with extra/plasma-framework5? [Y/n] y
:: Replace prison with extra/prison5? [Y/n] y
:: Replace purpose with extra/purpose5? [Y/n] y
:: Replace qqc2-desktop-style with extra/qqc2-desktop-style5? [Y/n] y
:: Replace solid with extra/solid5? [Y/n] y
:: Replace sonnet with extra/sonnet5? [Y/n] y
:: Replace syndication with extra/syndication5? [Y/n] y
:: Replace syntax-highlighting with extra/syntax-highlighting5? [Y/n] y
:: Replace threadweaver with extra/threadweaver5? [Y/n] y
resolving dependencies...
looking for conflicting packages...
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: jdk-openjdk and jre-openjdk are in conflict

It seems like that there is a conflict between jdk-openjdk and jre-openjdk. Yesterday I saw this forum answer on the Arch forum: https://bbs.archlinux.org/viewtopic.php?id=290066 . Does it also apply to this conflict?

Thank you for your tip! To be honest I always use yay than I insert my root password. I wrote sudo yay just to make sure that everybody knew that I was giving the root permits and that it wasn’t a problem linked to root privileges.

Incoming changes in JDK / JRE 21 packages may require manual intervention - Important notifications - EndeavourOS



Hi Bonk! Thank you for your kind answer!
You saved me!!
That thread had all the infos I was looking for!

That’s what worked for me:

  1. node-lts-gallium → using this link that I found in the thread you linked I was able to find out that it was (and it is) required by github-desktop 3.3.3-1 AUR package. I solved the gallium issue by unistalling github-desktop, updating the system, rebooting and then installing github-desktop-bin 3.3.3_linux2-1 AUR package
  2. JDK - JRE conflict, by simply applying what was written in the thread.

Now the system is updated and everything works perfectly apart from DaVinci Resolve (when I click on the icon nothing happens - even looking at htop) :cry: but I guess it has nothing to do with this thread so I’ll keep banging my head against the wall for a week or so and then I will open another thread :sweat_smile:.

Thank you all for the precious help!!

I don’t know whether this may help someone, but I managed to get DaVinci Resolve to work. Here’s what worked for me:

Problem: DaVinci Resolve couldn’t start because the libpango/glib system library differed too much from the ones Resolve ships. You can find more details in the Arch Wiki.


  1. Run DaVinci Resolve from the terminal:

LD_PRELOAD="/usr/lib64/libglib-2.0.so" /opt/resolve/bin/resolve

  1. To get the desktop shortcut to work, edit the com.blackmagicdesign.resolve.desktop file, which is located in ~/usr/share/applications. You can use a text editor like nano to do this.

  2. Find the following line:
    Exec= /opt/resolve/bin/resolve %u

  3. Replace it with the following line:
    Exec=LD_PRELOAD="/usr/lib64/libglib-2.0.so" /opt/resolve/bin/resolve %u

  4. If you are using an AMD graphics card, you may need to add the following to the Exec line:
    So the final Exec line would look like this:
    Exec=LD_PRELOAD="/usr/lib64/libglib-2.0.so" progl /opt/resolve/bin/resolve %u

  5. Once you have made the changes, save the file and reboot your system.

DaVinci Resolve should now start normally.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.