Unable to Update after Fresh Install (SSL certificate not valid) - Solved

Hello all! Longtime user of Antergos and using EndeavorOS for my Arch installs. I’m a longtime Linux user but I don’t consider myself a power user. I ran into a problem while setting up some laptops that I am stumped on. I Just downloaded the latest ISO from the website: endeavouros-2019.10.15-x86_64.iso Install went off without a problem and first boot was fine. Trying to run an update using pacman -Syu and I am getting the follow error message:

failed retrieving file ‘endevouros.db’ from github.com : SSL certificate problem: certificate is not yet valid.

I can install individual apps but cannot do a complete update. Searched the message boards but didn’t find anything that seemed relevant.

Is there an obvious fix that I missed somewhere?

Thanks in advance!

Welcome to forum!

It might be a temporary problem, have you tried updating again?
If that doesn’t help, could you show here the actual input and output of your update command?

Is your date and time set up correctly?

Actually no, it isn’t, I realized that shortly after posting the question though I wasn’t certain if that was related to my problem. Typing timedatectl status I get the message that my system clock is not synchronized and ntp service is inactive. Shouldn’t these be active on a clean install and how do I go about activating them?

Looks like timedatectl set-ntp true did the trick. Now I am no longer getting the SSL is not yet valid error.

sudo systemctl enable --now systemd-timesyncd.service

sudo systemctl enable --now systemd-time-wait-sync.service

would be the systemd option to enable time sync… we have this included in the next ISO

Thank you!

You may mark this as “solved”.

1 Like


1 Like