Unable to Login or Use WiFi Networks - Need Advice!

So I have recently installed EndeavourOS onto my Laptop and yesterday I decided that I would add a new user to the system so that my default user doesn’t have sudo rights and so in the event of my system being compromised it is far less likely that they’ll be able to easily cause any significant damage.

The problems I’m facing are;

1.) CONSTANT and I really do mean NON-STOP requests for me to enter Wireless Network Credentials even when the credentials are correct.
KWallet is the application that is making the constant pop-ups appear so it could be an issue with that (More on this in a second).

2.) When LOCKING but NOT logging out of my newly created user I am unable to log back in using the password I just made and assigned to them, this is even stranger because if I then select the “Switch Users” option and then select the newly made user and type in the same password, it logs me in just fine…

I am now wondering if this issue is with EndeavourOS, KDE, or, KWallet.
Now for me, my money is on KWallet being the cause of these problems, but seeing as I ran Manjaro KDE for 2 years and never had any issue even remotely like this I can only assume that it’s either a newly created bug with KDE Plasma/KWallet, OR, It is a bug that affects only EndeavourOS!

Being unable to use WiFi on a laptop makes it really cumbersome to use.

Being unable to login after locking the system makes using the laptop for anything far more difficult.

Any help solving this would be appreciated

Make sure the package kwallet-pam is installed.

I am not sure I understand this one. You create a new user, lock the screen and then try to login as the new user?

I’ll install kwallet-pam asap then in regards to that first point I made.

In regards to the second point, what I mean is this;

I have 2 user accounts on the system, if I use the first account that I setup when I originally installed the distro, I can login & logout just fine, and, I can “Meta+L”|“Windows+L” to lock the user and then use my password again to unlock and go back to doing whatever it is I was doing.

But, if I login using the 2nd account that was made a few days after the initial installation and then I use the same “Meta+L” shortcut to lock the user session but NOT logout, when I get back to the system and want to login again it refuses to do so and states that my password is wrong (even though that’s impossible because I use a hardware key that autotypes the password the same way every time without failure), so it means that I can’t log back in.

The only option at that stage is the “Switch User” option, and, If I click that button it loads up the SDDM login screen as expected and all seems fine, but, it isn’t, because if at this stage I try to login as either user, regardless of which user I choose, I type the password, press the enter key, and poof, SDDM now locks itself up and I can no longer do anything with it.

At this stage TTY still works and I can go back to the Locked User session from the start, only it is still broken and refuses to accept my password even though I know that the password is correct.

I have no idea what’s causing this to happen but it’s a complete mess, and, it makes using multiple accounts pretty much a non-existent option because if I leave the PC and it auto-locks for security, or if I want to auto-lock it myself, I can’t, and so it makes my system less secure as I have to use an account with sudo access at all times which simply isn’t an option for my line of usage.

Sorry for such a long message, I just wanted to make sure I’m providing you with as much detail as I can in the hopes that it might make it easier to identify the issue.

I understand now. Try installing kwallet-pam and rebooting first. I am not sure if that solves the problem or not but if it doesn’t we can troubleshoot further.


Okay, I’ll do that now.

So an update on the situation as a whole…

The issue now seems to be resolved completely as I am no longer able to get the system to fail on login after locking a user session.

I don’t know if the “plasma-workspace” package update is what fixed it,
Or, if it was the installation of the “kwallet-pam” package that occurred at the same time that I updated,
Or, if it was a result of me changing the hardware key password to a new one that seemed to not have strange self-encoding behaviour when used in the KDE environment. (This behaviour could not be replicated in other text boxes or desktop environments, so it was really niche/strange to see.)

But as a result of the three above changes I can now successfully lock the system and unlock the user session again without any issues, and I have tested this across 4 different accounts on the system to ensure that it is working as expected.

I’d like to thank @dalto for their help in resolving this matter as well as the mystery person on the EndeavourOS Official Matrix chat who also suggested the same thing a few hours prior.

Thank you both for welcoming me into this community!

(I will mark this as the solution, but please do read the entire thread to get context of how I came to this conclusion.)


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.