Unable to change root apps settings in gnome

Launching gedit with “sudo gedit” command and trying to change its settings like fonts,color scheme etc is giving following error in terminal.

“dconf-WARNING **: 21:08:37.212: failed to commit changes to dconf: Error spawning command line “dbus-launch --autolaunch=28afd2e42ba741c882a4e2b1731e7637 --binary-syntax --close-stderr”: Child process exited with code 1”.

Is there any way to fix this ??

Don’t run gedit as root? Generally speaking, you should never run any graphical applications as root.\


Welcome aboard! :rocket:

Check this:

Well sometimes you have to, like sudo nvidia-settings which will have low-dpi defaults on 4k screen

1 Like

Hopefully you don’t have to run that so frequently that you are trying to run gedit to improve it’s theming…

1 Like

Now that this issue is solved, I’d just like to take this opportunity to mention in passing…

On KDE Plasma, the default text editor is Kate (Kate is Advanced Text Editor), which is not only superior in every way to Gedit, but also has polkit integration, which allows it to edit root owned files without being run as root (which, of course, you should never do with any GUI application).

So, I don’t know… Maybe give Plasma a try, maybe you’ll like it. I hear it’s pretty great… :wink:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.