Unable to Boot USB Key

I got a new laptop Lenovo ThinkPad X13 Gen 3 (AMD). I installed the latest ISO on a USB using popsicle. I’ve tried disabling all the security features and windows features in the BIOS. In the boot menu when I select my USB I get a black screen and I am thrown back to the main menu. Ventoy works, but when I select an ISO I get a white line on a black screen. I was able to boot into the Lenovo BIOS update iso which I installed using popsicle.

does the usb drive work on another PC? Perhaps try using the “dd” command instead of popsicle to write the ISO image to the usb drive

Is it normal the disk type sets itself to dos? I’m pretty sure it should be GPT

Seems ok. Looks like the one I created with the DD command yesterday:

Festplatte /dev/sde: 57,75 GiB, 62008590336 Bytes, 121110528 Sektoren
Festplattenmodell: DataTraveler 3.0
Einheiten: Sektoren von 1 * 512 = 512 Bytes
Sektorgröße (logisch/physikalisch): 512 Bytes / 512 Bytes
E/A-Größe (minimal/optimal): 512 Bytes / 512 Bytes
Festplattenbezeichnungstyp: dos
Festplattenbezeichner: 0x4d909e77

Gerät      Boot  Anfang    Ende Sektoren Größe Kn Typ
/dev/sde1  *         64 3789951  3789888  1,8G  0 Leer
/dev/sde2       3789952 4023423   233472  114M ef EFI (FAT-12/16/32)

So I’ve tried with DD and 2 USBs. One of which I have used before with a previous endeavour ISO. None of those show up on my desktop’s boot menu, but they show on the laptop and do a black screen then I am brought back to the main menu.

Did you disable the bios option “Secure Boot”?

I did.

Well the laptop is Ubuntu certified. Did you try to use the ubuntu iso to see if this works?

Perhaps there is a bios update available that you could install first, that fixes this behaviour?

Thank you, I got it successfully working with DD, I had to use the following sudo dd if=/home/zangoku/Downloads/EndeavourOS_Cassini_Nova-03-2023_R1.iso of=/dev/sdf bs=16M oflag=direct. I am not sure if it was specifying this blocksize or oflag that did it for me as it was not working with a blocksize of 4M.


Glad to hear that it’s working now. Have fun with :enos: :grinning:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.