Unable to Boot into System After Update

Hello! First time post here. Please let me know if my formatting may be improved.

I’ve been using EndeavourOS for a while now, several months at least. This laptop I am using is a Lenovo Legion with a dual boot system of EOS and Windows 11.
This morning I booted up and ran the updater. It had maybe 10 updates or so. I noticed a lot of things for haskell, and I think I saw something related to the Linux kernel.
Update completed normally and I was told to reboot because of system updates. Upon doing so, I am unable to boot back into the system.

When grub appears, I indicate to boot into EOS. At that point it displays the startup log, though this time there is substantial text. It says something about modules not loading, much more text scrolls by rather quickly, and then it goes into a long and (apparently) very slow process.
Right now the top line says [ 22.675181] kauditd_printk_skb: 56 callbacks suppressed.
I have seen many lines that suggest some sort of audit, eg.
[ 903.3326821] audit: type=1131 audit(1653829907.786:103): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-backlight@backlight:acpi_video0 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
There’s another currently visible line with the msg='unit=systemd-tmpfiles-clean..., or msg='unity=user-runtime-dir@120, or msg='unit=systemd-hosnamed.

These lines appear, some in a short cluster. Others appear one line at a time every 5-20 minutes. I haven’t been measuring the time. Many of these lines end in res=success, which seems promising… Though this process is exceedingly long. This computer normally boots in seconds and this “audit” has taken at least a half hour. I tried various approaches. The power key stops the process and turns off the computer, even if only pressed briefly. I tried booting into the other Linux option (fallback intramfs or something) and it behaves the same. I am leaving it running in hopes that it would complete, though it has been stuck on the last line for a long while now.
I would certainly appreciate some clarification on what’s going on, and/or any suggestions as to what I should do about this. I’m happy to provide any more information, though I am unable to get into my system to run commands. I could boot into Windows or perhaps a live USB, though I’ll leave this running for now until something happens or I give up. :slightly_smiling_face:
Thank you for your time!

Give it a minute or so to boot and then try pressing ctrl+alt+f3 and see if that brings you to a login prompt.

If that works, either use a wired network or use the command nmtui to connect to your wireless network.

Then run:

sudo pacman -Syu linux-lts linux-lts-headers

Once you reboot try selecting the LTS kernel from the list.


Do you have a NVIDIA GPU and Intel 11/12 Gen CPU? If yes try booting with ibt=off kernel parameter.


Oh my goodness; thank you for the rapid response!

In saw somewhere before I made this original post to try Ctrl+Alt+F2. When I tried it at the time, it switched to a blank “log”. Trying F2 and F3 now take me to separate login prompts. Upon logging in, I am greeted with the fish prompt.
I followed the steps you added and was able to get things up successfully.

Should the LTS kernel be used as the primary, or should I stick to the standard option and use LTS for “backup”?

Thank you very much for your assistance!


That is a personal preference and also depends on your specific hardware. I tend to use the LTS kernel whenever I can. Especially when a new kernel is released. The first few point releases of a new kernel often introduce problems.


The GPU is NVIDIA and the core is an Intel i7. I’ve never booted with custom parameters, though I’ll do a bit of searching about it and check into it. Thank you for your suggestion!

Glad you got your issue resolved!

Please check the “solution” box under @dalto’s post for the forum software to consider the thread as solved and for other users with similar issue to find the solution easily.

1 Like

Understood. I will keep this in mind. Thank you all (@dalto @pebcak @mrvictory) for providing a great experience for this newbie! It has brightened my day. Cheers!


Thanks and welcome to the forum!


Welcome to EnOS’ community @Sunonymous!

:enos_flag: :handshake:t5:


Welcome @Sunonymous


Another day, another problem being solved successfully. Always happy to see it! Also welcome to the community! :enos:

1 Like

a welcome from my side too @Sunonymous

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.