UEFI Issue?


I have a desktop machine with a single SSD drive in a removable caddie (not hotswap just shutdown machine and remove). I swap the drive to run different operating systems (Win 10, Endeavour etc) i recently installed Arch Linux with (XCFE 4) which also worked fine but i discovered that after i have booted with my EndeavourOS drive when i switch back to the Arch Linux drive my machine no longer thinks that the drive is bootable. Obviously Endeavour cannot have corrupted the Arch drive because it was not inserted in the machine when it was running so something must be happening with UEFI ?

I can make my Arch drive work again by booting from the Arch ISO USB and running the following commands (not sure if this is all necessary but it works):-

grub-install --target=x86_64-efi --efi=directory=/efi --bootloader-id=GRUB
grub-mkconfig -o /boot/grub/grub.cfg

Just to confirm that i only need to do the above with switching back to Arch after booting with the Endeavour drive, i can switch between the Win 10 and Arch drives without issues.

Thanks in advance for any advice.

1 Like

Try adding --removable and see if the EFI variables will survive a removal and re-plugg:

grub-install --removable --target=x86_64-efi --efi=directory=/efi --bootloader-id=GRUB


Thanks - That seems to have worked!


Does the EndeavourOS installer use --removable ?

I am not sure, but I wouldn’t think so. I don’t think Calamares (the installer) will distinguish if it is a removable or an internal disk you are installing to.

Another thing you might check is whether the installer executed a ‘boot coup’. The NVRAM storage might well be ‘pointing’ to the EnOS entry, and be getting confused when it isn’t there! F8, and do a re-order is one way to handle things - adding grub stanzas for the ‘missing’ systems is another - and removing irrelevant NVRAM entries is another. You should not have to regenerate anything to ‘correct’ it.


I would agree with that statement too. :wink: