UEFI Grub and BIOS Grub in parallel

BIOS

Típus: ATA KINGSTON SA400S3 (scsi)
/dev/sda lemez: 480GB
Szektorméret (logikai/fizikai): 512B/512B
Partíciós tábla: gpt
Lemezjelzők:

Szám Kezdet Vég Méret Fájlrendszer Név Jelzők
1 17,4kB 134MB 134MB msftres
2 135MB 690MB 555MB ntfs diag
3 690MB 795MB 105MB fat32 boot, esp
4 795MB 368GB 368GB ntfs msftdata
5 368GB 398GB 29,8GB ext4
10 398GB 431GB 33,1GB ext4
6 431GB 440GB 8389MB linux-swap(v1) swap
7 440GB 471GB 31,5GB ext4
8 471GB 480GB 8389MB linux-swap(v1) swap
9 480GB 480GB 538MB bios_grub, legacy_boot

EFI variables are not supported on this system.

1 Like

Thanks for the outputs!

This confirms @dalto’s comment above. Your systems are installed in a “mixed” mode.
Your EnOS is definitively installed in Bios mode as shown per the output of the first command above.

What is puzzling me is the fact that EnOS grub picks up Kubuntu. This would imply that Kubuntu is also installed in Bios mode. But you wrote:

At any rate, you would need to ascertain that all the systems are installed in the same mode.

I think when another Linux system is booted from grub’s boot menu the other’s system boot.img and core.img are not needed and therefore grub boots the other Linux system at an elevated stage where the differences in booting between UEFI and BIOS do not matter anymore.

1 Like

Just because grub is installed on a small fat32 partition doesn’t mean it’s using efi?

1 Like

Could you show file /boot/grub/grub.cfg on EOS?
Probably it is starting Kubuntu from a grub menu entry directly without using UEFI stuff at all.

You might be able to start Windows from EOS grub by writing the following into
file /boot/grub/custom.cfg:

menuentry 'Windows 10 (custom.cfg)' {
  savedefault
  search --set --fs-uuid XXXX-XXXX  # EFI partition uuid on your system, see: lsblk -fm
  chainloader /EFI/Microsoft/Boot/bootmgfw.efi
}

Thank you as my time allows, I will try and give feedback.

Custom.cfg did not exist, so I created it. After entering the code you suggested, I received an invalid signature error message.

Ok, it didn’t work.
Would be nice to see the full message though.

In fact, if I click on the Windows 10 entry, that’s all the message is, after which the grub main menu returns after a while. I was inattentive because during the EOS offline installation, during a manual partitioning, I created a new FAT32 small partition for BIOS Grub in response to a warning window. Otherwise, the installer would probably have overwritten the UEFI grub created when installing Kubuntu on the other, original EFI partition.

Actually, many different setups can co-exist on as UEFI partition. A directory is created to hold grub’s start file only, the actual grub info is kept on /boot for that particular system. You can only run in to trouble if UEFI is too small for how many you have installed. For instance I have 8 systems on one computer without crowding UEFI partition (500mb).

1 Like

If you haven’t checked, it is possible that your BIOS/firmware supports something like Hybrid BIOS (or whatever name with your motherboard vendor, means support for both UEFI and legacy BIOS boot). Worth checking, it might help.

Fwiw, when you do an UEFI installation, the systems installed put their bootloaders in their own folders on ESP. In your case, EnOS would have just added a new folder with its bootloader alongside the other ones already on ESP.

I also have a 500 MB EFI partition.

You’re right, in the BIOS I can toggle between just UEFI, legacy, or both. Depending on the start settings, one or the other grub will start. Thank you.

In the meantime, the problem is solved, meters from the installed Kubuntu grub menu, EndeavourOS can also be started, although only in fallback mode. Thank you all for your constructive comments.

The quick and dirty way to fix the fallback thing is likely to be an incorrect entry by the grub os-prober from the other system. If you change the line:

initrd	/boot/amd-ucode.img 

(obviously if Intel powered, it will read /boot/intel-ucode.img) to

initrd	/boot/amd-ucode.img /boot/initramfs-linux.img

in the file /boot/grub.cfg it will probably ‘fix’ the problem.
The reason this is ‘dirty’ is that the file WILL be overwritten on every grub update, and need to be ‘fixed’ again.

What I would do myself is install rEFInd, and let it do the whole thing. We have a wiki entry on that right here, and nothing is required beyond the install to see if it works.

BTW - I wrote the wiki, so I'm biased!)

Thanks for your valuable reply, I will give it a try. What is the disadvantage of fallback mode compared to normal startup?

The normal startup has been configured (using autodetect for example) for your system. The Fallback option skips autodetect, and leaves everything (including the kitchen sink) in the startup. It can help with tracking down problems with hardware, or misconfiguration for instance.

Thanks. This “dirty” method worked.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.