Tuptime errors - seems to require root?

It worked fine in previous installation.

I know I’m doing something wrong.

tuptime

I’m thinking I should change the permissions to the tuptime.db? :thinking:

from the github site of tuptime

Run first with a privileged user:

tuptime

that means:

sudo tuptime

I tried the tuptime package from the AUR. I only had to use sudo the first time I started the software. then the command ‘tuptime’ is enough. the permissions are the same for me.

[pycrk@EnOS tuptime]$ exa -l
.rw-r--r-- 8,2k root  5 Sep 20:31 tuptime.db
[pycrk@EnOS tuptime]$ tuptime
System startups:        1  since  20:30:50 05.09.2022
System shutdowns:       0 ok  +  0 bad
System life:            14m 31s

System uptime:          100.0%  =  14m 31s
System downtime:        0.0%  =  0s                                                                                                                                                           
                                                                                                                                                                                              
Average uptime:         14m 31s                                                                                                                                                               
Average downtime:       0s                                                                                                                                                                    

Current uptime:         14m 31s  since  20:30:50 05.09.2022
[pycrk@EnOS tuptime]$ 

I did that buddy.
But it seems to require that every time I reboot :thinking:

as i just read it runs with sudo for security reasons, but according to the maintainer you can solve it as follows.

sudo nano /lib/systemd/system/tuptime.service

then look for the line ‘User=_tuptime’ under [service] and insert the character ‘#’ in front of it.

#User=_tuptime
'ctrl+x' and 'y ' to save it 'enter'

than reboot

Edit: https://github.com/rfrail3/tuptime/issues/43#issuecomment-475569900

Much appreciated.

Replacing nano with nvim and giving it a shot later :+1: :stuck_out_tongue_winking_eye:

1 Like

as written earlier, sudo is used for security reasons. the solution above works according to the maintainer, but it is not recommended.