Trying to make 130 work

So I am trying to make my Nvidia Mx130 work with my integrated graphics.
I am using the LTS Kernel right now.
The first problem that occured is the nvidia-lts.
image

When i try to install dkms it says that there is a conflict and i should remove the nvidia-lts package

Looks like the list of the dependencies on the web page needs an update:

$ pacman -Si nvidia-lts
Repository : extra
Name : nvidia-lts
Version : 1:520.56.06-9
Description : NVIDIA drivers for linux-lts
Architecture : x86_64
URL : https://www.nvidia.com/
Licenses : custom
Groups : None
Provides : NVIDIA-MODULE
Depends On : linux-lts nvidia-utils=520.56.06 libglvnd
Optional Deps : None
Conflicts With : None
Replaces : None
Download Size : 41.16 MiB
Installed Size : 41.18 MiB
Packager : Andreas Radke andyrtr@archlinux.org
Build Date : Wed 16 Nov 2022 12:51:10 PM CET
Validated By : MD5 Sum SHA-256 Sum Signature

I suspect you are misunderstanding something.
You don’t need (or should) install (nvidia-)dkms, in order to install nvidia-lts. The dependency is only for the package creation, which (package) is already created.

Just install the package you want (nvidia-lts).
Or am I misinterpreting?

Don’t (necessarily) check the packages’ webpage for info. Use pacman and its commands.

2 Likes

Right. I should have payed attention to make within ( ).

@pebcak :ballot_box_with_check:

1 Like

Is there a way i can use my mx130 for docker etc. bc as i can see it never gets used