Trying to Install on Old Asus 2 in 1

I have an old Asus 2 in 1, which has windoze installed and I use it with Resilio as my own personal cloud.
Trying to boot from USB, it boots from the installed windoze, though I have a menu:

  • Windows
  • Setting (or something to enter Bios)
    I select the USB, but it takes a moment then boots Windoze.
    I copied the ISO to USB using dd command and it went fine.
    This is my machine:
System Manufacturer
System Model
System Type
 X86-based PC
System SKU
 Intel(R) Atom(TM) CPU Z3735D @ 1.33GHz, 1329 Mhz, 4 Core(s), 4 Logical Processor(s)
BIOS Version/Date
 American Megatrends Inc. T100TAL.209, Tuesday, 21, Oct
SMBIOS Version 2.7
Embedded Controller Version
BaseBoard Manufacturer ASUSTeK COMPUTER INC.

And this is the ISO:


Does it boot windoze because this ISO is “beyond” the machine power?
Any guidance highly appreciated.
P.S. I burnt several times and different USB sticks. Still same!

There could be several reasons:

  1. Secure boot could be enabled
  2. Your iso download could be bad or it could be a bad burn to media
  3. The machine could have some other boot limitation

If I was a betting man, I would bet on #1.


Thanks a lot @dalto . Instant replies as usual. I didnt even have the chance to read what I posted :rofl:

But I believe it is not a problem.
Anyway, I tried to disable from BIOS, I got something windoze asking for key. (as if it skipped the USB and went to windoze)

Like what? What to do about it?

You know, having a windoze thing really irritates me, though it is RIP under a desk where I cant even see it.


As far as I can remember I installed on this laptop I’m using now which had windoze on it, and from a USB, (can’t honestly remember what I did with the EFI/UEFI/Secure Boot stuff), but it actually booted from USB.
So, I don’t know why not this machine is skipping to windoze whether secure boot enabled or disabled.

Because that is what happens when secure boot is enabled. It tries to boot off the USB but can’t because it isn’t signed. It then looks for somewhere else to boot and find the installed copy of windows.

1 Like

So, let me try again disable secure boot… and maybe I’ll play with some other stuff (hoping I won’t brick it).
I will post back.
Thank you.

Unless “some other stuff” is throwing it out of skyscraper - it’s not possible to brick :upside_down_face:

I tried disabling secure boot, it took me again to windoze thing asking for key. Then a few trials, something flashed in my old head.
I think long ago when I got it I knew something like the OS is not on the disk it is on a chip (SoC), which means -I think- it is impossible to over write the operating system! :cry:
Maybe that’s why I was kept away from Linux all that time. :cry: :angry:


I noticed I may be missing:

4. Now you need to make a grub.cfg.

I don’t know how to do it?

Though this is TLDR, I read it quickly… no, not for me thanks.

Maybe the first Arch link…

I think this tablet is a 32 bit Windows device.

says it is 64 bit. Though the installed windows is 32 bits! I never knew why :astonished:

Can anybody tell if it is 32/64 bit? Should I try another 32 bit ISO, if any?

I guess the processor is 64 bit then. When you try to disable secure boot it’s asking for keys? Is there another setting somewhere to remove the keys first?

could it be this is one of this devices that has 64 CPU but a 32bit only UEFI?

1 Like

Not I know of! This machine from what I read from the links has something “special”. It is not a standard machine.

I thought of something “evil” :imp: that will either make it or break it.
I go to the windows system folders and delete it, so it wont have windoze to boot… :skull: but I am worried it is a SoC so won’t make difference. So, mostly it will break it :astonished:

Honestly I don’t know. But I can conclude that they installed a 32 bit windoze if I try a 32 bit Linux it might work!!!?

There is no 32 bit EOS? If there is link?

Update: currently downloading antiX-19.4_386-base.iso

nope but still:

I’m a bit worried, AFAIK, Arch is not that graphic/automatic installation. Sorry (a bit old impatient man here) :blush:

But you know what! I’ll go for it… I love challenge! Downloading now. :imp: :nerd_face:

That was what i was thinking why i mentioned it.