Troubles with Keyboard Backlight after kernel update

Got troubles with managing my keyboard backlight.
Currently I’m on i3 and managed it with sysfs and tuxedo-drivers-dkms for my hardware.

# Backlight control
set $get_backlight ~/.config/i3/my_scripts/backlight
set $get_kb_bk  ~/.config/i3/my_scripts/kb_backlight

bindsym XF86MonBrightnessUp exec --no-startup-id brightnessctl set +2%  && notify-send "Brightness - $(exec $get_backlight)" 
bindsym XF86MonBrightnessDown exec --no-startup-id brightnessctl set 2%- && notify-send "Brightness - $(exec $get_backlight)"

#KEYBOARD BACKLIGHT
bindsym XF86KbdBrightnessUp exec --no-startup-id brightnessctl set -d rgb:kbd_backlight +5% && notify-send $($get_kb_bk)
bindsym XF86KbdBrightnessDown exec --no-startup-id brightnessctl set -d rgb:kbd_backlight 5%- && notify-send $($get_kb_bk)

Today i updated my system and it didn’t go well (laptop gone off during kernel installation) and i had to fix it through arch-chroot. I ran reinstall-kernells to fix it. When i logged in again everything was fine, except for keyboard backlight.
Noticed that my kbd_backlight in /sys/class/leds/ gone.

roman@laptop /s/c/leds> ls
enp8s0f1-0::lan@  enp8s0f1-2::lan@    input22::numlock@     input4::capslock@  input4::scrolllock@
enp8s0f1-1::lan@  input22::capslock@  input22::scrolllock@  input4::numlock@   phy0-led@

Reinstalling drivers doesn’t help. Before tuxedo drivers, i was using clevo-xsm-wmi, as my hardware provider said.
Some info about OS:
inxi -Fxxc0z | eos-sendlog
journalctl -k -b -0 | eos-sendlog

                     ./o.                   roman@laptop
                   ./sssso-                 ------------
                 `:osssssss+-               OS: EndeavourOS rolling x86_64
               `:+sssssssssso/.             Host: NHx0DB,DE
             `-/ossssssssssssso/.           Kernel: Linux 6.9.1-arch1-1
           `-/+sssssssssssssssso+:`         Uptime: 29 mins
         `-:/+sssssssssssssssssso+/.        Packages: 1361 (pacman)
       `.://osssssssssssssssssssso++-       Shell: fish 3.7.1
      .://+ssssssssssssssssssssssso++:      Display (eDP-1): 1920x1080 @ 144Hz
    .:///ossssssssssssssssssssssssso++:     WM: i3 (X11)
  `:////ssssssssssssssssssssssssssso+++.    Theme: Arc-Dark [GTK2/3]
`-////+ssssssssssssssssssssssssssso++++-    Icons: Qogir-dark [GTK2/3]
 `..-+oosssssssssssssssssssssssso+++++/`    Font: Noto Sans (10pt) [GTK2/3]
   ./++++++++++++++++++++++++++++++/:.      Cursor: Qogir-dark (16px)
  `:::::::::::::::::::::::::------``        Terminal: xfce4-terminal 1.1.3
                                            Terminal Font: Source Code Pro (10pt)
                                            CPU: Intel(R) Core(TM) i5-10200H (8) @ 4,10 GHz
                                            GPU: Intel UHD Graphics 610 @ 1,05 GHz [Integrated]
                                            Memory: 3,98 GiB / 15,32 GiB (26%)
                                            Swap: Disabled
                                            Disk (/): 28,07 GiB / 475,96 GiB (6%) - btrfs
                                            Disk (/home/roman/Drives): 75,55 GiB / 856,21 GiB (9%) - btrfs
                                            Local IP (wlan0): 192.168.1.102/24 *
                                            Battery: 96% [Charging]
                                            Locale: en_US.UTF-8

                                            ████████████████████████
                                            ████████████████████████
roman@laptop ~> sudo dmesg | grep -e keyboard
[    1.946472] input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input4
56: PS/2 00.0: 10800 Keyboard
  [Created at input.226]
  Unique ID: c3zD.+49ps10DtUF
  Hardware Class: keyboard
  Model: "AT Translated Set 2 keyboard"
  Vendor: 0x0001 
  Device: 0x0001 "AT Translated Set 2 keyboard"
  Compatible to: int 0x0211 0x0001
  Device File: /dev/input/event4
  Device Files: /dev/input/event4, /dev/input/by-path/platform-i8042-serio-0-event-kbd
  Device Number: char 13:68
  Driver Info #0:
    XkbRules: xfree86
    XkbModel: pc104
  Config Status: cfg=new, avail=yes, need=no, active=unknown

Also getting troubles with building package clevo-xsm-wmi:

==> Starting build()...
make -C /lib/modules/6.9.1-arch1-1/build M=/home/roman/.cache/paru/clone/clevo-xsm-wmi/src/tuxedocomputers-clevo-xsm-wmi-6bfe9fe44e04/module modules
make[1]: Entering directory '/usr/lib/modules/6.9.1-arch1-1/build'
/usr/lib/modules/6.9.1-arch1-1/build/Makefile:759: arch//Makefile: No such file or directory
make[2]: *** No rule to make target 'arch//Makefile'.  Stop.
make[1]: *** [Makefile:240: __sub-make] Error 2
make[1]: Leaving directory '/usr/lib/modules/6.9.1-arch1-1/build'
make: *** [Makefile:7: all] Error 2
==> ERROR: A failure occurred in build().
    Aborting...
error: failed to build 'clevo-xsm-wmi-1.1-3': 
error: packages failed to build: clevo-xsm-wmi-1.1-3

Am I getting those troubles because of interrupted kernel update?

Solved issue by reinstalling the kernel. Maybe there was another solution.

roman@laptop ~> ls /sys/class/leds | grep -e kbd
rgb:kbd_backlight

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.