Trouble with Suspend on Endeavour_OS – Need Help with systemd-boot

Hey Endeavour_OS community,
I’ve been encountering an issue with my laptop’s suspend functionality in Endeavour_OS. On other Linux distros with GRUB bootloader, I was able to resolve a similar problem by tweaking the GRUB configuration in “/etc/default/grub.” Specifically, I added “acpi_osi=! acpi_osi=’Windows 2009’” just before “quiet” in the GRUB_CMDLINE_LINUX_DEFAULT line.
However, Endeavour_OS uses systemd-boot, and I’m struggling to figure out the equivalent solution. I attempted using sudo kernelstub -a "acpi_osi=! acpi_osi=’Windows 2009'", but unfortunately, it doesn’t seem to have any effect.
Has anyone else faced a similar issue with systemd-boot on Endeavour_OS? If so, could you kindly share your insights or a workaround to help me get suspend working again?
Your assistance is greatly appreciated! Thanks in advance.

Try adding your kernel boot parameters to

… the file /etc/kernel/cmdline which is a one-line file containing a list of kernel options. Then run sudo reinstall-kernels which will populate the entries and regenerate the initrds.
https://discovery.endeavouros.com/installation/systemd-boot/2022/12/