Trouble updating with Pamac

I recently installed Endeavour and overall it’s running very well. :slight_smile:

Except I noticed that after installing Pamac I’ve noticed that when trying to do updates Pamac gets stuck in a loop and doesn’t upgrade. I turn it off and use the terminal running # pacman -Syu and upgrades install smoothly.

Has anyone else noticed this glitch?

It has been suggested to use Pamac classic over the AUR version which is newer. I do notice it too and it is better to use pacman. You can also use yay which will also update the AUR with yay -Syu or if you want to update the AUR only you can use yay -Sua.

thats mostly issue of pamac , never update with it , endeavouros ships with kalu works fine as news reciever and updater. kalu does exist before pamac is reliable didnt changed so much… kalu is more reliabler to update then pamac as my subjective opionion :slight_smile: pacman is always better because is upstream maintained and better in manyways, since pamac is an alien , you have to be carefull of it.

but if you want to continue to use it , you can try this : https://bbs.archlinux.org/viewtopic.php?pid=1854109#p1854109 probably in pamac setting, update loops is happend in current pamac also versions before.

The above solution worked for me.

set parallel downloads to zero is the solution for this :wink:

2 Likes

Pamac has been unreliable for a long time, that’s why it hasn’t been included in the official packages. However, pamac may be useful for searching info about packages.

As said here, pacman is reliable, and yay seems to handle AUR software well.

i got a bunch i dont need to have package info of pamac , from repo pcurses can give also lot info. but is cli offcourse :slight_smile: as gui there is many more, but understandble, lots arch based going with it currently with it currently…(pamac)

I take it this is just in the newer AUR version of Pamac?

Take note that Pamac is flagged as out of date in the AUR.

I think it worked! :wink: