Trouble Setting Refresh Rate to 144hz

I’m having trouble getting my PC to go to 144hz and stick there.

I have 2 monitors both supporting 144hz. I’ve set them to 144hz in the Xfce display settings as well as nvidia-settings. One monitor seems fine but my main monitor is very obviously not running at 144hz. Even the mouse pointer is laggy when dragging it across that screen where I’ll see a trail of mouse pointers behind the position.

Refresh checking websites show 60hz. glxgears runs at 1500 fps, and doesn’t say it’s syncing to the refresh rate at all. If I run a game and enable vsync, it sets the FPS to 60.

If I run pfkill X and log back in, those websites do show 144hz. Running glxgears will sync to the vertical refresh rate and run at 144 fps. Games will vsync to 144 FPS.

All is fine and good until I reboot. Then everything is back to juttering and running 60hz again until I kill X. Any ideas as to why it resets and then runs fine once I kill X on a boot?

Not sure if it will help, but here’s /etc/X11/xorg.conf:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 460.56

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"

Section "Files"

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "LG Electronics LG ULTRAGEAR"
    HorizSync       230.0 - 230.0
    VertRefresh     48.0 - 144.0
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 1070"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-6"
    Option         "metamodes" "DP-2: nvidia-auto-select +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}, DP-4: 2560x1440_144 +2560+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24

Trying to figure out the issue, I went ahead and installed Plasma to see if it was something specific to Xfce. The issue persisted. But then I swapped the display manager to SDDM and everything was fine in Plasma.

Testing further, I also installed Gnome.

lightdm has the issue on Gnome, Plasma, and Xfce
lxdm has the issue on Gnome, Plasma, and Xfce
GDM will start a Gnome or Xfce session with no problems, 144Hz from boot
SDDM will start a Plasma or Xfce session with no problems, 144Hz from boot

So it seems as though the issue might not be an Xorg issue but instead a lightdm (and lxdm) issue?

For now I’m just running GDM into Gnome. I like the lightness of Xfce but it feels wrong to go GDM → not Gnome. Plus I’m a sucker for the super key multitasking view of all windows Gnome has.

So in practical terms, my issue is resolved as I can get to a desktop at the proper refresh rate without having to kill X on every boot, but I’m still interested in finding out what the issue really is.

1 Like

Just install plasma and enjoy! :wink:

But… but… but… My super key gnome window switching view. Or my super light weight Xfce session so I don’t use up too much RAM.

My preference is to run lightdm into Xfce for the lightest weight option. But since that doesn’t work, I’ll settle on GDM into Gnome for the awesome multi tasking view. Even though Gnome has its own issues (hangs for several minutes on a reboot but that’s a problem to tackle another day :laughing: )

I’ve also read that installing more than one DE at a time is a bad idea due to conflicts.

Not if you install them on another drive. :grinning:

1 Like