Trouble making Bootable usb

Greetings: I am trying to get up and running on an HP Z400 workstation which has an older Radeon GPU RX 650 I think. I am actually trying to replace vanilla Arch on her. I only have CLI because neither Xorg nor waylaid likes ANY video driver and either ends up locked up ( can’t use control-alt-f2,) mouse is also unresponsive! Set up .xinitrc and tried startx but it only flashes and then just says exited properly. Tried all ati and AMD GPU (including pro) no go.

So now want to get EOS installed. This is apparently a BIOS machine. So since I can only boot into CLI, downloaded the EOS ISO using wget and can’t seem to get it burned successfully. I am using DD as the site prescribed but even though my system supports USB booting and will boot from the arch iso I burned a while back, all attempts to boot the EOS ISO just end up bypassing that thumb drive. On my system, you hit f9 when bios screen appears and it will give you a menu, I select USB and it tries but immediately boots back to the ssd (hdd) and I am back on my arch system. Not sure how to proceed because unless the ISO I downloaded for corrupted, I am at a loss. Btw also tried manjaro and made the iso the same way, but it locks up just like all my other Xorg tries. I have deinstalled all video drivers and went to mesa only when the machine last booted a GUI and it was actually Wayland only but the only resolution I could use was 1280x760 which is not my monitors native. It is 1280x1024 and that resolution was on a nvidia Nvs legacy card. The ATI always worked fine in my old rig. Anyhow, hope someone can help!

Michael Needham

Just a note to let you all know what a dunce I am. I didn’t set up the wget right and did corrupt the original download. It boots now and so far is not frozen in the installer / live environment!

Thanks for anyone who took time to read my post, gut it is resolved. I feel very silly and of course I do write Python​:blush: